How do i remove 02's? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-10-2013, 03:55 PM   #1
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
How do i remove 02's?

I cant seem toget my 02s off
Attached Thumbnails
Click image for larger version

Name:	image-4111813230.jpg
Views:	85
Size:	479.4 KB
ID:	107177  
Rich04 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-10-2013, 05:59 PM   #2
Registered Member
Regular
 
Slow4V's Avatar
 
Join Date: Feb 2013
Location: Sa
Region: Alabama
Posts: 2,208
Quote:
Originally Posted by Rich04 View Post
I cant seem toget my 02s off
Get a wrench and use some balls lol
Slow4V is offline   Reply With Quote
Old 05-10-2013, 06:01 PM   #3
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
You can rent a o2 socket from auto zone
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-10-2013, 06:12 PM   #4
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
I heated it up and used a 7'8 open end and nothin ill try auto zone thanks
Rich04 is offline   Reply With Quote
Old 05-10-2013, 06:57 PM   #5
ME Bloodhound
Staff
 
Soccerluvr4's Avatar
 
Join Date: Feb 2012
Location: Sacramento/Bay Area
Region: California
Posts: 14,672
Either a crescent wrench or vice grips, and some balls
__________________

Bullitt build paused pending graduation

HID end all thread
Soccerluvr4 is offline   Reply With Quote
Old 05-10-2013, 07:53 PM   #6
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
I got the rental and yeah still not coming off i tried heating it up and gettin at it. It will not work
Rich04 is offline   Reply With Quote
Old 05-10-2013, 08:00 PM   #7
Registered Member
Regular
 
Join Date: Jan 2011
Region: Arkansas
Posts: 704
Quote:
Originally Posted by Rich04 View Post
I got the rental and yeah still not coming off i tried heating it up and gettin at it. It will not work
Like everyone else said, you just have to torque them out. It took me several tries before I broke mine loose on my old 6er. I just use a rubber mallet and hit the end of the wrench while I hold it on the sensor now. It's much easier.
BackPressure is offline   Reply With Quote
Old 05-10-2013, 09:23 PM   #8
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
They will not come out what is the thread size on the 02 im gonna plug then is it 18mm?
Rich04 is offline   Reply With Quote
Old 05-10-2013, 09:41 PM   #9
Registered Member
Regular
 
White03GT's Avatar
 
Join Date: Mar 2013
Location: Hereford
Region: Texas
Posts: 1,057
Try some break loose **** and balls, or leverage.
White03GT is offline   Reply With Quote
Old 05-10-2013, 10:20 PM   #10
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
Quote:
Originally Posted by White03GT View Post
Try some break loose **** and balls, or leverage.
Got em off !!
Rich04 is offline   Reply With Quote
Old 05-10-2013, 11:41 PM   #11
Registered Member
Regular
 
White03GT's Avatar
 
Join Date: Mar 2013
Location: Hereford
Region: Texas
Posts: 1,057
Quote:
Originally Posted by Rich04 View Post

Got em off !!
Kudos! How?
White03GT is offline   Reply With Quote
Old 05-10-2013, 11:43 PM   #12
Registered Member
Regular
 
MidnightBlueGT's Avatar
 
Join Date: Apr 2013
Location: Charlotte
Region: North Carolina
Posts: 3,887
Quote:
Originally Posted by White03GT View Post

Kudos! How?
Used those balls
MidnightBlueGT is offline   Reply With Quote
Old 05-10-2013, 11:47 PM   #13
Registered Member
Regular
 
White03GT's Avatar
 
Join Date: Mar 2013
Location: Hereford
Region: Texas
Posts: 1,057
Quote:
Originally Posted by MidnightBlueGT View Post

Used those balls
Ha
White03GT is offline   Reply With Quote
Old 05-11-2013, 12:06 AM   #14
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
I had a blue torch my friend said it wasn't strong enough toook out the yellow one and twisted off!
Rich04 is offline   Reply With Quote
Old 05-11-2013, 12:20 AM   #15
ME Bloodhound
Staff
 
Soccerluvr4's Avatar
 
Join Date: Feb 2012
Location: Sacramento/Bay Area
Region: California
Posts: 14,672
PB blaster and some muscle is how i got them off. And mine had 140k on them.
__________________

Bullitt build paused pending graduation

HID end all thread
Soccerluvr4 is offline   Reply With Quote
Old 05-11-2013, 12:26 AM   #16
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
Idk these things were in there and the mid pipe was changed, cause it was a catted H
Rich04 is offline   Reply With Quote
Old 05-11-2013, 10:50 AM   #17
Registered Member
Regular
 
White03GT's Avatar
 
Join Date: Mar 2013
Location: Hereford
Region: Texas
Posts: 1,057
Quote:
Originally Posted by Soccerluvr4 View Post
PB blaster and some muscle is how i got them off. And mine had 140k on them.
+1

---------- Post added at 10:50 AM ---------- Previous post was at 10:50 AM ----------

Quote:
Originally Posted by Rich04 View Post
I had a blue torch my friend said it wasn't strong enough toook out the yellow one and twisted off!
That's good man
White03GT is offline   Reply With Quote
Old 05-12-2013, 02:16 PM   #18
Registered Member
Regular
 
Cornkush's Avatar
 
Join Date: Mar 2013
Location: Indianapolis
Region: Indiana
Posts: 171
Long pipe as leverage on your wrench . Long pipe... Big balls ..
Cornkush is offline   Reply With Quote
Old 05-12-2013, 02:58 PM   #19
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
Quote:
Originally Posted by Cornkush View Post
Long pipe as leverage on your wrench . Long pipe... Big balls ..
Musta had some big balls cause i broke the pipe
Rich04 is offline   Reply With Quote
Old 05-12-2013, 03:05 PM   #20
Registered Member
Regular
 
Cornkush's Avatar
 
Join Date: Mar 2013
Location: Indianapolis
Region: Indiana
Posts: 171
What kinda pipe did you use ? Lead or thick steel?
Cornkush is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:38 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.