took the car to the dragstrip, no longer able to shift gears - clutch dead? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-08-2013, 09:28 PM   #1
Registered Member
Regular
 
Join Date: Oct 2011
Region: Canada
Posts: 27
took the car to the dragstrip, no longer able to shift gears - clutch dead?

Took my 2000 GT 5-speed with just mild bolt-ons (251rwhp) with street tires to the drag strip today, and on my first pass launching from idle, the RPMs suddenly went high gears 1 through 4 but the car was hardly accelerating..

When I slowed down and tried to shift gears the car would no longer shift. I had to turn the car off, then I managed to shift the gear into first and restart the car...

The car lurched forward in 1st gear upon restart, and the only way I could shift gears was without the clutch, but rev-matching the synchros and managing to shift into higher gears.

The clutch pedal feels fine, so I do not think it is a snapped cable. The car also smells like burnt clutch, and there was a bunch of smoke on my first and only run at the drag strip following my car.

Anyone know what it could be? Should I expect more damage than just a destroyed clutch? Flywheel? I didn't really feel any vibrations driving the car at 60mph back home in 5th. I have a new valeo clutch (king cobra kit) for the car.
__________________
2000 Atlantic Blue GT
paradigm is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-08-2013, 11:44 PM   #2
Registered Member
Regular
 
Krazy Horse's Avatar
 
Join Date: Jul 2012
Region: Alabama
Posts: 178
Sounds like you ate the clutch disc on your pass. May have lost one of the springs inside the disc itself
Krazy Horse is offline   Reply With Quote
Old 06-09-2013, 01:31 AM   #3
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Pop the little canister on the bottom by the clutch. If little shreds of like wood type are there than you might of ate the clucth and from what you stated that's what I believe it is
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-09-2013, 09:27 AM   #4
Registered Member
Regular
 
Join Date: Oct 2011
Region: Canada
Posts: 27
Quote:
Originally Posted by Venomouz831 View Post
Pop the little canister on the voting by the clutch. If little shreds of like wood type are there than you might of ate the clucth and from what you stated that's what I believe it is
Where is this little canister you speak of? I am not sure what the voting is?
__________________
2000 Atlantic Blue GT
paradigm is offline   Reply With Quote
Old 06-09-2013, 10:09 AM   #5
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
The inspection cover. Two bolts hold it on and should be on the driver side of the transmission under the car.
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 06-09-2013, 10:27 AM   #6
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Quote:
Originally Posted by lowflyn View Post
The inspection cover. Two bolts hold it on and should be on the driver side of the transmission under the car.
Yep
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 06-10-2013, 08:51 AM   #7
Registered Member
Regular
 
MustangGT02's Avatar
 
Join Date: Jun 2011
Location: MO
Region: Missouri
Posts: 437
I had a POS valeo in my car when I did my first autocross in my stang. It did the same thing, I all the sudden had no clutch, turns out the clutch was shattered into a bunch of the wood type shreds like stated above. I now have a RAM clutch and I can tell the valeo was just junk.
MustangGT02 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:59 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.