Exhaust installed...weird noise - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-11-2013, 12:21 PM   #1
Registered Member
Regular
 
MidnightBlueGT's Avatar
 
Join Date: Apr 2013
Location: Charlotte
Region: North Carolina
Posts: 3,887
Exhaust installed...weird noise

So i just finished installing my bassani o/r x and catback and when i accelerate up to about 2300 rpm it makes like a whistle sound but in neutral doesnt do it. Is that alright?
Just worries me...
MidnightBlueGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-11-2013, 12:25 PM   #2
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Did you make sure everything is tightened really good
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 06-11-2013, 12:34 PM   #3
Registered Member
Regular
 
MidnightBlueGT's Avatar
 
Join Date: Apr 2013
Location: Charlotte
Region: North Carolina
Posts: 3,887
Tightened good the first time. Went for a heat cycle an is cooling down right now before i touch it.
What i dont understand is why is it only when i accelerate? Maintaining speed clean sound no drone or anything. In neutral clean. But accelerating just at 2300 makes a squeal or whistley sound.
So maybe just bolts need retightened?
Hopefully...
MidnightBlueGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-11-2013, 02:03 PM   #4
Registered Member
Regular
 
Mathew r Wright's Avatar
 
Join Date: Sep 2011
Region: Oklahoma
Posts: 470
Quote:
Originally Posted by MidnightBlueGT
Tightened good the first time. Went for a heat cycle an is cooling down right now before i touch it.
What i dont understand is why is it only when i accelerate? Maintaining speed clean sound no drone or anything. In neutral clean. But accelerating just at 2300 makes a squeal or whistley sound.
So maybe just bolts need retightened?
Hopefully...
Are you sure that's your exhaust making that noise?
Mathew r Wright is offline   Reply With Quote
Old 06-11-2013, 02:10 PM   #5
Registered Member
Regular
 
Kevo91's Avatar
 
Join Date: Apr 2013
Location: Magna
Region: Utah
Posts: 298
How dramatic is it? If you have a CAI the better flowing exhaust could just be sucking in more air in. Get out and rev your throttle body and have a listen
Kevo91 is offline   Reply With Quote
Old 06-11-2013, 02:11 PM   #6
Registered Member
Regular
 
MidnightBlueGT's Avatar
 
Join Date: Apr 2013
Location: Charlotte
Region: North Carolina
Posts: 3,887
Didn't happen when i drove it an hour before...

---------- Post added at 03:11 PM ---------- Previous post was at 03:11 PM ----------

I do have a cai
MidnightBlueGT is offline   Reply With Quote
Old 06-11-2013, 02:11 PM   #7
Registered Member
Regular
 
Kevo91's Avatar
 
Join Date: Apr 2013
Location: Magna
Region: Utah
Posts: 298
Oh. Hmm i dunno then
Kevo91 is offline   Reply With Quote
Old 06-11-2013, 02:13 PM   #8
Registered Member
Regular
 
Mathew r Wright's Avatar
 
Join Date: Sep 2011
Region: Oklahoma
Posts: 470
Quote:
Originally Posted by Kevo91
How dramatic is it? If you have a CAI the better flowing exhaust could just be sucking in more air in. Get out and rev your throttle body and have a listen
This sounds good to me. So your saying a hr before you didn't have a supercharged pony and now you do lol...
Mathew r Wright is offline   Reply With Quote
Old 06-11-2013, 02:14 PM   #9
Registered Member
Regular
 
Kevo91's Avatar
 
Join Date: Apr 2013
Location: Magna
Region: Utah
Posts: 298
I have a cold air on my truck with the 5.0 and once i put headers and high flow cats on it started whistling thru the air filter when i hit the gas

---------- Post added at 01:14 PM ---------- Previous post was at 01:13 PM ----------

Quote:
Originally Posted by Mathew r Wright View Post

This sounds good to me. So your saying a hr before you didn't have a supercharged pony and now you do lol...
? I dont have a supercharger
Kevo91 is offline   Reply With Quote
Old 06-11-2013, 02:16 PM   #10
Registered Member
Regular
 
Mathew r Wright's Avatar
 
Join Date: Sep 2011
Region: Oklahoma
Posts: 470
Quote:
Originally Posted by Kevo91
I have a cold air on my truck with the 5.0 and once i put headers and high flow cats on it started whistling thru the air filter when i hit the gas

---------- Post added at 01:14 PM ---------- Previous post was at 01:13 PM ----------



? I dont have a supercharger
I know I was just being funny...
Mathew r Wright is offline   Reply With Quote
Old 06-11-2013, 10:20 PM   #11
Registered Member
Regular
 
Count Dragula's Avatar
 
Join Date: Mar 2013
Location: Warner Robins
Region: Georgia
Posts: 1,320
It's just an exhaust leak more than likely. Of course it wouldn't do it in neutral that's lower rpms and the exhaust gas isn't moving as fast. Just make sure you tighten everything again. Plug the tips so not much exhaust can come out and see if there is a leak.
__________________
2007 Mustang Gt
2.3L Whipple Supercharger
Brenspeed Detroit Rocker Supercharger Cams
3.73 Gears
XXR 521 Wheels
20x8.5 and 20x10.5
Count Dragula is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:50 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.