97 Ford Mustang - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-15-2013, 10:15 PM   #1
Registered Member
Regular
 
Join Date: Jan 2012
Region: South Carolina
Posts: 47
97 Ford Mustang

My 97 Mustang will not crank. At first the lights would come on now it won't do anything at all. No lights, horn, and it will not click. Please help ASAP!!! Thank you very much.
caulderk is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-15-2013, 10:17 PM   #2
Registered Member

Regular
 
Ubnbit's Avatar
 
Join Date: Jan 2013
Location: Tazewell
Region: Tennessee
Posts: 3,532
Have u tried the battery? Check the terminals? Jump it off? What all have u done/not done?
__________________
Tint, louvers, Shelby brake light cover, sequentials, brake vent ring delete, Shorty antenna, JLT cold air intake, BAMA tune, VMP 2.5 S/C pulley, Ford racing shifter, MRT OR-H, SLP loudmouths, BMR adj PHB, BMR LCA, Eibach Pro-Kit, cobra jet big oval TB.
Ubnbit is offline   Reply With Quote
Old 06-15-2013, 11:20 PM   #3
Registered Member
Regular
 
Join Date: Jan 2012
Region: South Carolina
Posts: 47
I did. After about 2 1/2 hours it cranked. I think there is an electrical problem. Do you know anyone in Charleston SC that specializes in electrical problems? Thanks.
caulderk is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-15-2013, 11:25 PM   #4
Registered Member

Regular
 
Ubnbit's Avatar
 
Join Date: Jan 2013
Location: Tazewell
Region: Tennessee
Posts: 3,532
Not a clue. Somebody else might.

Check all the fuses. Look for wires bare that are touching, check the ground cable to see if its loose.
__________________
Tint, louvers, Shelby brake light cover, sequentials, brake vent ring delete, Shorty antenna, JLT cold air intake, BAMA tune, VMP 2.5 S/C pulley, Ford racing shifter, MRT OR-H, SLP loudmouths, BMR adj PHB, BMR LCA, Eibach Pro-Kit, cobra jet big oval TB.
Ubnbit is offline   Reply With Quote
Old 06-15-2013, 11:29 PM   #5
Registered Member
Regular
 
Join Date: Jan 2012
Region: South Carolina
Posts: 47
I will do that.
caulderk is offline   Reply With Quote
Old 06-15-2013, 11:50 PM   #6
Registered Member
Regular
 
Kevo91's Avatar
 
Join Date: Apr 2013
Location: Magna
Region: Utah
Posts: 298
Its either your battery or alternator is bad. Jump it if you need to, get a volt meter and put it on the terminals, if it reads less than 13 at idle its your battery. If it reads over 13 but goes down at 2k rpms its your alt. Also check the back top of the alternator, there are these 2 cables that plug in and they are famous for coming unplugged

---------- Post added at 10:50 PM ---------- Previous post was at 10:46 PM ----------

Or if you dont have a volt meter autozone can test them for free
Kevo91 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:13 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.