Temperature guage? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-11-2013, 09:21 PM   #1
Registered User
Newbie
 
Join Date: Jul 2013
Location: New port richey
Region: Florida
Posts: 1
Temperature guage?

Just bought 96 gt vert, 4.6 sohc temp gauge ran in the "A" so I swapped out the oe stat for a 170 . No change in the gauge, Used an electronic thermo to check to top hose, temp never got over 198 fan cycles properly. Anybody ever have a bad gauge or sensor in a 96? All help appreciated. Thanks!
Doug817 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-11-2013, 09:51 PM   #2
Staff
Regular
Staff
 
scottydsntknow's Avatar
 
Join Date: Apr 2013
Location: JB MDL
Region: New Jersey
Posts: 16,576
Yep, could be a bad gauge or sensor. I'd go get a nice aftermarket gauge for water and oil and throw them in an autometer cluster bezel if I were you.
__________________
2000 Mustang GT Steeda #0048

Just because I give you advice, doesn't mean I know more than you. Its just means I've done more stupid ****.
scottydsntknow is online now   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:17 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.