Diesel sounding engine - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-26-2013, 02:06 PM   #1
Registered Member
Regular
 
Join Date: Aug 2012
Region: Texas
Posts: 117
Diesel sounding engine

So I just changed all cops and plugs but the misfire didn't go away. I rechecked my work and all seems good. The engine shakes slightly at idle and also sounds like a small diesel.

The youtube videos i've seen are way way louder than mine. Mine also smooths out with more rpms. Any ideas?

Might have to pull out the engine
Apex Predator is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-26-2013, 03:14 PM   #2
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Exhaust leak?
Billymich is offline   Reply With Quote
Old 07-26-2013, 03:36 PM   #3
Registered Member
Regular
 
Count Dragula's Avatar
 
Join Date: Mar 2013
Location: Warner Robins
Region: Georgia
Posts: 1,320
Mine was a bad injector
__________________
2007 Mustang Gt
2.3L Whipple Supercharger
Brenspeed Detroit Rocker Supercharger Cams
3.73 Gears
XXR 521 Wheels
20x8.5 and 20x10.5
Count Dragula is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-26-2013, 04:24 PM   #4
Registered Member
Regular
 
Join Date: Dec 2010
Posts: 1,291
To me that sounds like timing chain slap against the timing chain guides. No after market cams or anything ? To rule out what was said above about the injector move the suspected bad injector from the cyn that's misfiring to another cyn. If the misfire swaps from one cyn to the other you found your problem.
southernstang00 is offline   Reply With Quote
Old 07-26-2013, 04:45 PM   #5
Registered Member
Regular
 
Join Date: Aug 2012
Region: Texas
Posts: 117
Checked injectors and they are in working order. Why couldn't the CEL just lit up!
Car drives but i rather not, exhaust sounds like crap. Calling it quits for today.
Apex Predator is offline   Reply With Quote
Old 07-30-2013, 03:40 PM   #6
Registered Member
Regular
 
Join Date: Aug 2012
Region: Texas
Posts: 117
Well I disconnected the battery for about 45 minutes and connected it again. Car is not making the noise and the misfire is now very minimal at idle only. Car drives smooth and has power. I believe the small misfire is due to do a leaking spark plug on cylinder 4 where i had a blow out a few months ago. Might just end up replacing the heads.
Apex Predator is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



03:17 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.