flasher fuse blows and no brake lights/turn signals - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-18-2013, 02:49 AM   #1
Registered Member
Regular
 
CCSOdeputy's Avatar
 
Join Date: Aug 2013
Location: Kannapolis
Region: North Carolina
Posts: 48
flasher fuse blows and no brake lights/turn signals

I recently took my lights off and tinted them. Since reinstall, my brake lights amd turn signals won't work and my flasher fuse (fuse 18) keeps blowing. Any suggestions?
CCSOdeputy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-18-2013, 03:04 AM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Check your wires...maybe u frayed something and its grounding out.
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 08-18-2013, 03:20 AM   #3
Registered Member
Regular
 
CCSOdeputy's Avatar
 
Join Date: Aug 2013
Location: Kannapolis
Region: North Carolina
Posts: 48
Thanks. Will do.
CCSOdeputy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-18-2013, 12:41 PM   #4
Registered Member
Regular
 
MidnightBlueGT's Avatar
 
Join Date: Apr 2013
Location: Charlotte
Region: North Carolina
Posts: 3,887
Welcome bud! Lol. Guessing the new fuses didnt work...
MidnightBlueGT is offline   Reply With Quote
Old 08-18-2013, 01:02 PM   #5
Registered Member
Regular
 
CCSOdeputy's Avatar
 
Join Date: Aug 2013
Location: Kannapolis
Region: North Carolina
Posts: 48
I got it! It was a frayed wire beimg grounded in the tail lights. That caused my signal amd brake fuse to keep blowing
CCSOdeputy is offline   Reply With Quote
Old 08-18-2013, 01:05 PM   #6
Registered Member
Regular
 
MidnightBlueGT's Avatar
 
Join Date: Apr 2013
Location: Charlotte
Region: North Carolina
Posts: 3,887
Was it just one? I figured somewhere since every fuse put in would blow, just didnt make sense.
Good to go?
MidnightBlueGT is offline   Reply With Quote
Old 08-18-2013, 01:08 PM   #7
Registered Member
Regular
 
CCSOdeputy's Avatar
 
Join Date: Aug 2013
Location: Kannapolis
Region: North Carolina
Posts: 48
I'm street legal now baby! Hahaha. It was just one grounded wire and 2 fuses. But I'm good to go now
CCSOdeputy is offline   Reply With Quote
Old 08-18-2013, 01:11 PM   #8
Registered Member
Regular
 
MidnightBlueGT's Avatar
 
Join Date: Apr 2013
Location: Charlotte
Region: North Carolina
Posts: 3,887
Sounds good!
MidnightBlueGT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:49 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.