Pwer window help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-30-2013, 01:01 PM   #1
Registered Member
Regular
 
JB_MUSTANG_V6's Avatar
 
Join Date: Aug 2012
Region: Pennsylvania
Posts: 110
Pwer window help

My window on the driver side randomly just stopped working. When I press the button it just makes a clicking noise. Is this just the button that went bad or is it the motor? Or is there a fuse? Please help
JB_MUSTANG_V6 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-30-2013, 01:32 PM   #2
Registered Member
Regular
 
JimmyMosqueda's Avatar
 
Join Date: Jun 2013
Location: Houston
Region: Texas
Posts: 270
Might need a new window regulator.
JimmyMosqueda is offline   Reply With Quote
Old 08-30-2013, 01:35 PM   #3
Registered Member
Regular
 
Semerollin's Avatar
 
Join Date: Feb 2013
Location: Gadsden
Region: Alabama
Posts: 53
Quote:
Originally Posted by JimmyMosqueda View Post
Might need a new window regulator.
Yep. Just did mine. If you leave it down like 1/8 inch it won't get stuck. Lame I know but it works.
Semerollin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-30-2013, 09:07 PM   #4
Registered Member
Regular
 
02 360R's Avatar
 
Join Date: Jul 2012
Region: Mississippi
Posts: 306
If you bump it pretty good under the handle inside the car, it'll start working again. I just did it today. The 1/8 trick works too, if you can remember every time.
02 360R is offline   Reply With Quote
Old 08-30-2013, 09:22 PM   #5
Registered Member
Regular
 
1lowGT's Avatar
 
Join Date: Dec 2011
Region: Missouri
Posts: 3,903
Mine does this occasionally. Bumping the door won't usually work. I click until it drops. But yes leave it rolled down just a hair and it'll always work. I leave mine down but if I forget then it stays up and won't work
__________________
2003 GT - full bolts ons, suspension, and drag radials
1998 cummins - 150hp injectors | FASS fuel kit | 4" straight pipe | 5" lift | BHAF | 20" wheels | edge juice w/ attitude | built auto trans with stall | closing in on 900tq | bigger turbo soon..

Follow me on instagram @nicknold for car and truck pictures
1lowGT is offline   Reply With Quote
Old 08-31-2013, 10:40 PM   #6
Registered Member
Regular
 
XSlashDashX's Avatar
 
Join Date: Nov 2011
Location: Silsbee
Region: Texas
Posts: 1,224
Mine does it when sits out in the sun. But works when it cools off.
XSlashDashX is offline   Reply With Quote
Old 09-01-2013, 10:48 AM   #7
Registered Member
Regular
 
1lowGT's Avatar
 
Join Date: Dec 2011
Region: Missouri
Posts: 3,903
Wire gets hot and expands and loses connection then cools off and works.
__________________
2003 GT - full bolts ons, suspension, and drag radials
1998 cummins - 150hp injectors | FASS fuel kit | 4" straight pipe | 5" lift | BHAF | 20" wheels | edge juice w/ attitude | built auto trans with stall | closing in on 900tq | bigger turbo soon..

Follow me on instagram @nicknold for car and truck pictures
1lowGT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:50 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.