Rear defrost not working - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-05-2013, 07:00 AM   #1
Registered Member
Regular
 
Join Date: Jul 2013
Location: Pittsburgh
Region: Pennsylvania
Posts: 60
Question Rear defrost not working

As the title says the rear defrost in my 00 GT is not working. I know this is a vague question, but does anyone have any idea what might be wrong? Not sure if there is a common problem or if anyone has ran into this problem before. Please if anyone knows of any fixes let me know! I would like to try and fix this myself instead of taking to dealership.
Bill36 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-05-2013, 08:29 AM   #2
Registered Member
Regular
 
JimmyMosqueda's Avatar
 
Join Date: Jun 2013
Location: Houston
Region: Texas
Posts: 270
Are the plugs behind the plastic trim connected?
JimmyMosqueda is offline   Reply With Quote
Old 09-05-2013, 09:07 AM   #3
Registered Member
Regular
 
Join Date: Jul 2013
Location: Pittsburgh
Region: Pennsylvania
Posts: 60
Quote:
Originally Posted by JimmyMosqueda View Post
Are the plugs behind the plastic trim connected?
Yes, they both are. That was the first thing I thought was maybe one of them were disconnected.
Bill36 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-05-2013, 09:18 AM   #4
Registered Member
Regular
 
fomoco4life's Avatar
 
Join Date: Aug 2012
Location: Antioch
Region: California
Posts: 839
Fuses are a good place 2 start
fomoco4life is offline   Reply With Quote
Old 09-05-2013, 09:37 AM   #5
Registered Member
Regular
 
Join Date: Jul 2013
Location: Pittsburgh
Region: Pennsylvania
Posts: 60
Quote:
Originally Posted by fomoco4life View Post
Fuses are a good place 2 start
Thank you! I will check those when I am home today. Any other suggestions?
Bill36 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:57 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.