clutch adjusting/ tb noise help please - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-02-2013, 12:27 AM   #1
Registered User
Newbie
 
Join Date: Oct 2012
Region: California
Posts: 15
clutch adjusting/ tb noise help please

so i recently replaced the clutch tb, pb, and all that stuff in there with the exedy stage two stuff for my 04 gt. its been about 2500 miles since that and now my tb is making the same noise it made before it went completely out, clutch feels ok sometimes and then sometimes it feels too soft.... in the very beggining i didnt have that problem at all. anyways when im driving its a pretty faint sound and goes away when i push the clutch in to right before it starts to disengage, anything before that it makes the noise, at stop lights and such too while im in neutral.

anyways i called exedy and they said it could be a stretched cable? im not very familar with clutch cables or anything but ive read that they self adjust and that there are adjusting cables as well for adjusting at the clutch fork. so what would you guys reccomend that i do?
brandon151 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-02-2013, 01:22 AM   #2
Registered Member
Regular
 
Slow4V's Avatar
 
Join Date: Feb 2013
Location: Sa
Region: Alabama
Posts: 2,208
Quote:
Originally Posted by brandon151 View Post
so i recently replaced the clutch tb, pb, and all that stuff in there with the exedy stage two stuff for my 04 gt. its been about 2500 miles since that and now my tb is making the same noise it made before it went completely out, clutch feels ok sometimes and then sometimes it feels too soft.... in the very beggining i didnt have that problem at all. anyways when im driving its a pretty faint sound and goes away when i push the clutch in to right before it starts to disengage, anything before that it makes the noise, at stop lights and such too while im in neutral. anyways i called exedy and they said it could be a stretched cable? im not very familar with clutch cables or anything but ive read that they self adjust and that there are adjusting cables as well for adjusting at the clutch fork. so what would you guys reccomend that i do?
Did you use the exedy TOB ?

And did you lube it up real good ? / Fork too
Slow4V is offline   Reply With Quote
Old 10-02-2013, 01:38 AM   #3
Registered User
Newbie
 
Join Date: Oct 2012
Region: California
Posts: 15
yes and yes, i lubed the shaft on the tranny, the ball where the fork goes but not the fork itself... ive read on some other sites that its somewhat normal for the noise to be there but i dont really believe that.. car has 90500 miles by the way.
brandon151 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-02-2013, 06:20 AM   #4
Registered Member
Regular
 
Slow4V's Avatar
 
Join Date: Feb 2013
Location: Sa
Region: Alabama
Posts: 2,208
Quote:
Originally Posted by brandon151 View Post
yes and yes, i lubed the shaft on the tranny, the ball where the fork goes but not the fork itself... ive read on some other sites that its somewhat normal for the noise to be there but i dont really believe that.. car has 90500 miles by the way.
That's were you messed up, never use aftermarket TOBs always replace with ford OEM or better ford racing professional products they are the best and won't make noise
Slow4V is offline   Reply With Quote
Old 10-02-2013, 08:01 AM   #5
Staff
Regular
Staff
 
scottydsntknow's Avatar
 
Join Date: Apr 2013
Location: JB MDL
Region: New Jersey
Posts: 16,610
Agreed, use the FRPP one. I've done multiple King Cobra clutches that come with the FRPP TOBs and NEVER had an issue.
__________________
2000 Mustang GT Steeda #0048

Just because I give you advice, doesn't mean I know more than you. Its just means I've done more stupid ****.
scottydsntknow is offline   Reply With Quote
Old 10-02-2013, 12:48 PM   #6
Registered User
Newbie
 
Join Date: Oct 2012
Region: California
Posts: 15
damn.. haha i was gonna buy the king cobra clutch but literally every single vendor had them on back order for like a month and i needed my car back.
anyways i cant really pull the tranny again anytime soon to put a frpp one in there do you think ill be ok running it for now?
brandon151 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:00 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.