Brake light coming on when applying brakes - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-03-2013, 07:24 AM   #1
Registered Member
Regular
 
PBrown92's Avatar
 
Join Date: Dec 2012
Location: Peachtree City
Region: Georgia
Posts: 79
Brake light coming on when applying brakes

When I really get on my brakes my brake light will come on. What could be causing this?
__________________
1997 black GT
BBK CAI
SLP Loudmouth cat back
PBrown92 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-03-2013, 08:00 AM   #2
Registered Member
Regular
 
ColeJohnson's Avatar
 
Join Date: Jan 2011
Location: Ketchikan, Alaska
Region: Louisiana
Posts: 2,507
I'm sure that's just a safety thing... I have noticed that at least 100% of the time I hit the brakes my brake lights come on. Now if the brake lights dont come on... That's bad news.
__________________

2016 Comp Orange GT (current)
Aurora - 2002 Boosted GT! (Sold, sadly)
ColeJohnson is offline   Reply With Quote
Old 11-03-2013, 08:39 AM   #3
Registered Member
Regular
 
schmitty426's Avatar
 
Join Date: Nov 2012
Location: Woodbury
Region: Minnesota
Posts: 523
Low brake fluid had the same problem a few weeks ago
schmitty426 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-03-2013, 08:59 AM   #4
Registered Member
Regular
 
Screaming Mach's Avatar
 
Join Date: Aug 2013
Location: Lebanon
Region: Missouri
Posts: 857
Mine came on when I need rear brakes don't know if its the same for 97s tho
Screaming Mach is offline   Reply With Quote
Old 11-03-2013, 09:35 AM   #5
Registered Member
Regular
 
White03GT's Avatar
 
Join Date: Mar 2013
Location: Hereford
Region: Texas
Posts: 1,057
Quote:
Originally Posted by ColeJohnson View Post
I'm sure that's just a safety thing... I have noticed that at least 100% of the time I hit the brakes my brake lights come on. Now if the brake lights dont come on... That's bad news.
+1... Dafuq
White03GT is offline   Reply With Quote
Old 11-03-2013, 10:05 AM   #6
Registered Member
Regular
 
ColeJohnson's Avatar
 
Join Date: Jan 2011
Location: Ketchikan, Alaska
Region: Louisiana
Posts: 2,507
I was just poking a bit of fun. Maybe you mean your ABS light pops on when you brake hard? Could you be a little more descriptive? Does your car hop when braking hard and does the brake pedal lose and gain pressure rapidly? Have you checked your brake fluid level? and your brake pads and rotors? The ABS sensor can get gunked up with little metal shavings and start malfunctioning a little... Cleaning that can sometimes help out a bunch.
__________________

2016 Comp Orange GT (current)
Aurora - 2002 Boosted GT! (Sold, sadly)
ColeJohnson is offline   Reply With Quote
Old 11-04-2013, 01:44 PM   #7
Registered Member
Regular
 
04beautyGT's Avatar
 
Join Date: Sep 2013
Location: Van
Region: Texas
Posts: 152
I can almost guarantee it's low brake fluid. While you're at it you might want to make sure you're not leaking brake fluid around the bleeder. Mine was leaking a while ago just because it wasn't tight enough. I don't know about all of the '96-04 Mustangs, but mine needed to be a little tighter than normal.
04beautyGT is offline   Reply With Quote
Old 11-04-2013, 06:30 PM   #8
Registered Member
Regular
 
Roguestang's Avatar
 
Join Date: Nov 2011
Location: Tampa
Region: Florida
Posts: 1,516
Quote:
Originally Posted by 04beautyGT View Post
I can almost guarantee it's low brake fluid. While you're at it you might want to make sure you're not leaking brake fluid around the bleeder. Mine was leaking a while ago just because it wasn't tight enough. I don't know about all of the '96-04 Mustangs, but mine needed to be a little tighter than normal.
+1

It'll take you two mins to pop the hood and check. Definitely low on fluid.
__________________
2000 Mustang GT-Former giggle gas addict
1990 Mustang GT w/ Vortech V3

***resident gun idiot***
Roguestang is offline   Reply With Quote
Old 11-05-2013, 07:54 AM   #9
Registered Member
Regular
 
PBrown92's Avatar
 
Join Date: Dec 2012
Location: Peachtree City
Region: Georgia
Posts: 79
Quote:
Originally Posted by Roguestang View Post
+1 It'll take you two mins to pop the hood and check. Definitely low on fluid.
Checked the fluid level. It was a tad bit low so I added some. Haven't taken it out for a drive yet but that was probably the issue.
__________________
1997 black GT
BBK CAI
SLP Loudmouth cat back
PBrown92 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:06 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.