electrical issue - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-26-2014, 11:10 PM   #1
Registered User
Newbie
 
Join Date: Apr 2014
Location: Englewood
Region: Ohio
Posts: 1
electrical issue

Hey guys i' m new here and I apologize if this has already been answered but I couldn't find a thing for it and I searched on the internet everywhere. I have a 98 GT and I was about to go for a cruise at night and after I started it up I went to turn the exterior lights on and not a single one came on. I thought maybe I had a bad headlight switch but then I noticed that my radio wasn't turning on. The only light that was on in the whole car was the airbag light. And I didn't have the airbag light before this problem occured. I tested all of the fuses with a test light and they all checked out fine. So I double checked and got the same results. So for giggles I tested the master fuse and as soon as I touched it with the test light everything kicked right back on. Made absolutely no sense to me. I tested to make sure they were going to stay on and went for a drive. While I was driving the radio and the lights kept clicking on and off and all of the gauges just started going whack. Almost like the car was resetting itself. The airbag light code is code 52 btw. I got back home and shut the car off and restarted it and it happened again. Tested the main fuse again and the lights came on but the radio stayed dead. I've checked every possible place that I can find wires and I even tried replacing light, radio, and other fuses. Would anybody possibly know what is going on with my car?
bcm443 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-28-2015, 12:55 PM   #2
Registered User
Newbie
 
Gt Byron's Avatar
 
Join Date: Jun 2014
Location: Bridgewater
Region: New Jersey
Posts: 16
I'm just spitballing here but I would test the battery and alternator out too.
Gt Byron is offline   Reply With Quote
Old 02-28-2015, 01:35 PM   #3
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
My Nissan did this until I replaced the master fuse you are referring to. I actually went through 3 in a year

Sent from my VS985 4G using Mustang Evolution mobile app
natestang07 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My 13' electrical issue bluemonster13 2011-2014 Mustang GT 19 12-19-2012 04:20 PM
electrical issue. Rob94gt 1979-1995 Mustang GT 4 08-23-2012 09:16 PM
electrical issue? Slvr01GT 1979-1995 Mustang GT 9 03-26-2012 04:33 PM
Electrical issue Seattle66 Classic Mustangs 10 02-24-2012 12:12 PM
Still chasing electrical issue... Project Pony Pre-2005 V6 Mustang 2 01-31-2012 06:08 PM

» Like Us On Facebook



03:56 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.