2004 mustang gt rough running with ac on - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-10-2014, 08:09 AM   #1
Registered User
Newbie
 
Join Date: May 2014
Posts: 3
2004 mustang gt rough running with ac on

Have 2004 mustang gt has procharger Full exhaust Msd coils etc etc. Issue started bout 5 years ago. Could go to car wash. Wash in out under hood upside down drive out runs fine . Next time barely rinse it off & it's was like injectors went wide open.then would sit for couple days & was fine.but the last time it happened it didn't clear up after sitting.spoke with procharger they figured maybe moisture getting in mafia so replace factory mass with lightening mass & eliminate mafia.runs better but still stumbles / misses.hasn't bin driven in almost 4 years has 12,000 miles other day I found it runs perfect with defrost or ac off.it's bin to 3 ford dealers & 2 dyno shops!! To no avail seems like tried everything any of any sort would be more than appreciated! Thx for ur time
pepe Girard is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-10-2014, 08:17 AM   #2
Registered User
Newbie
 
TheJoeBailey's Avatar
 
Join Date: Apr 2014
Location: Portsmouth, Virginia
Posts: 19
I am a noob but don't believe that owners manual recommend washing under the hood with a hose. For me I cleaned MAF sensor didn't clear up idle problem then replace fuel filter cleaned Idle Air Control Valve with a new gasket then replace boots and plugs runs like new now no problems.
TheJoeBailey is offline   Reply With Quote
Old 05-10-2014, 08:28 AM   #3
Registered User
Newbie
 
Join Date: May 2014
Posts: 3
I just rinse off engine never bin problem with any other vehicle or this one before.have cleaned or replaced everything could think of before brought it to dealer replaced o2 sensors, frps, coils,fuel filter,Injectors,plugs. Am thinking now that found it runs fine with ac off if not as simple as a low voltage issue even though it charges fine.dunno. I'm stumped as well as everywhere I bring it
pepe Girard is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-10-2014, 08:54 AM   #4
Registered Member
Regular
 
Join Date: Apr 2014
Location: Outside Chicago
Region: Illinois
Posts: 222
Quote:
Originally Posted by pepe Girard View Post
moisture getting in mafia
Hmmm. Well there's your problem.
Your car is sleeping with the fishes.
__________________
2012 Mustang Cyclone, 2002 Mustang GT, 2004 F150 FX4, 1999 Ranger O/R 4x4, 2007 Harley FXDB
jefx is offline   Reply With Quote
Old 05-10-2014, 09:04 AM   #5
Registered Member
Regular
 
Join Date: Apr 2014
Location: Outside Chicago
Region: Illinois
Posts: 222
jokes aside, I dont think its wise to pressure wash the engine. It is engineered to be guarded from the elements such as rain, snow, sun, etc. Thats why it is enclosed on 5 of its 6 sides, and the fender wells have splash guards.

Why are you pressure washing the engine in the first place? If it's getting that dirty from just driving the car, then I think you have some major issues.
__________________
2012 Mustang Cyclone, 2002 Mustang GT, 2004 F150 FX4, 1999 Ranger O/R 4x4, 2007 Harley FXDB
jefx is offline   Reply With Quote
Old 05-10-2014, 10:22 AM   #6
Registered Member
Regular
 
Mfore33's Avatar
 
Join Date: Feb 2012
Location: Murfreesboro
Region: Tennessee
Posts: 540
If it is running bad with the ac on it could be that the ac is about to go out. A worn out ac will have low oil in it and will pull more power away when running. My be time to get a new compressor and flush the system.
Mfore33 is offline   Reply With Quote
Old 05-10-2014, 12:33 PM   #7
Registered User
Newbie
 
Join Date: May 2014
Posts: 3
Nope. Nothing wrong with ac is either a wiring short when power put to ac or the lower rpm / voltage drop throws maf for a loop. Or is what it seems like. Picking up car from dyno shop today to do some more digging.was wondering if anyone else ever came across issue like this. Car has no miles. Always stored inside moisture got/ gets it somewhere shouldn't Somehow
pepe Girard is offline   Reply With Quote
Old 05-10-2014, 03:39 PM   #8
Registered Member
Regular
 
Join Date: Apr 2014
Location: Outside Chicago
Region: Illinois
Posts: 222
Quote:
Originally Posted by pepe Girard View Post
moisture got/ gets it somewhere shouldn't Somehow
probably from this:

Quote:
I just rinse off engine
Quote:
Wash in out under hood upside down
__________________
2012 Mustang Cyclone, 2002 Mustang GT, 2004 F150 FX4, 1999 Ranger O/R 4x4, 2007 Harley FXDB
jefx is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Tags
2004 mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
4.6 running rough / misfire 96Roushgt 1996-2004 Mustang GT 17 01-10-2013 11:53 AM
Car is running rough Nick.ward Pre-2005 V6 Mustang 9 01-09-2013 07:53 AM
Running Rough. ColeJohnson 1996-2004 Mustang GT 25 09-12-2011 04:46 PM
1999 ford mustang, running rough when getting hot? Grady 1996-2004 Mustang GT 1 03-08-2010 12:50 PM
Rough Idle and Rough Start Cajun JungleBoy Pre-2005 V6 Mustang 3 04-23-2006 11:33 PM

» Like Us On Facebook



11:18 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.