I have a 02 gt.. Anyone ever get a stuck turn signals? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-13-2014, 10:32 PM   #1
Registered Member
Regular
 
larrysgt's Avatar
 
Join Date: May 2012
Region: California
Posts: 144
I have a 02 gt.. Anyone ever get a stuck turn signals?

Turn signal stays on left or right and also the hazards stay on and don't turn off and on by itself.
Maybe relay?


Sent from my iPad using Mustang Evolution
larrysgt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-14-2014, 01:32 AM   #2
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,417
Yes.
The relay/flasher probably failed.
straybullitt is offline   Reply With Quote
Old 08-14-2014, 02:24 AM   #3
Registered Member
Regular
 
Join Date: Jun 2014
Location: Parniak
Region: Wisconsin
Posts: 618
blinker fluid or relay
TurboCobra is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-14-2014, 02:27 AM   #4
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,417
Fluid?
straybullitt is offline   Reply With Quote
Old 08-14-2014, 02:36 AM   #5
Registered Member
Regular
 
Join Date: Jun 2014
Location: Parniak
Region: Wisconsin
Posts: 618
Quote:
Originally Posted by straybullitt View Post
Fluid?
Your local auto parts store should carry some, just ask up at the counter
Attached Thumbnails
Click image for larger version

Name:	ROYAL.jpg
Views:	101
Size:	22.3 KB
ID:	163452  
TurboCobra is offline   Reply With Quote
Old 08-14-2014, 02:52 AM   #6
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,417
Lol.
I'll be sure to pick up a gallon the next time that I'm in there!
straybullitt is offline   Reply With Quote
Old 08-14-2014, 06:43 AM   #7
Registered Member
Regular
 
99_GRUMPY_GT's Avatar
 
Join Date: Aug 2014
Location: Cabo Rojo, P.R.
Region: Other
Posts: 590
If it were me I would take a look at the multi-function switch on the column. It has 3 plugs The multi-function switch is attached to your turn signal arm. Most times it has a short, or dirty connections or even a milted connection. Take a look at it, inspect the connections, clean, and see what that gets you.
__________________


2015 Race Red Performance Package GT 5.0 (435hp) stock
Still in the making Updates coming soon!
99_GRUMPY_GT is offline   Reply With Quote
Old 08-14-2014, 09:45 AM   #8
Registered Member
Regular
 
paulflor98's Avatar
 
Join Date: Aug 2012
Region: Texas
Posts: 77
Quote:
Originally Posted by 99_GRUMPY_GT View Post
If it were me I would take a look at the multi-function switch on the column. It has 3 plugs The multi-function switch is attached to your turn signal arm. Most times it has a short, or dirty connections or even a milted connection. Take a look at it, inspect the connections, clean, and see what that gets you.
+1

I had the same issue in my 02, the steering column has two or three screws on it holding the plastic covering, I had to replace the entire switch was not too expensive, it is the same one as alot of ford vehicles. I bought a used one from a junked ranger, fixed it up. Just make sure to try cleaning your contacts first.

Sent from my SAMSUNG-SGH-I337 using Mustang Evolution mobile app
paulflor98 is offline   Reply With Quote
Old 08-15-2014, 11:17 PM   #9
Registered Member
Regular
 
larrysgt's Avatar
 
Join Date: May 2012
Region: California
Posts: 144
Cool guys thanks


Sent from my iPad using Mustang Evolution
larrysgt is offline   Reply With Quote
Old 08-17-2014, 11:09 PM   #10
Registered Member
Regular
 
larrysgt's Avatar
 
Join Date: May 2012
Region: California
Posts: 144
We'll it was the flasher relay located under the steering wheel. Was getting stuck.


Sent from my iPad using Mustang Evolution
larrysgt is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No turn signals but have hazard lights. M_Wag 1996-2004 Mustang GT 4 10-18-2012 02:06 PM
FS: Plug-N-Play Sequential Turn Signals |We are a Site Sponsor| sequencers Mustang Parts for Sale and Wanted 2 12-02-2008 10:14 PM
Green Turn Signals, an illegal immigrant thang?? Rick0636 The Bar 28 10-04-2003 11:27 PM
Turn signals robert0803 Pre-2005 V6 Mustang 7 09-30-2003 11:52 PM

» Like Us On Facebook



03:03 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.