Charging Problems - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-28-2014, 08:31 PM   #1
Registered Member
Regular
 
mattski's Avatar
 
Join Date: May 2014
Location: CO Springs
Posts: 29
Charging Problems

For the last two days I've been trying to figure out why my battery keeps draining at idle and while driving. Took out the alternator and had it tested and it was good. So I figured maybe the battery? Took it and had it tested and it was also good. Checked all the connections and they were all tight. I've read about a fuseable link somewhere in the harness that I have yet to look for.
Trying to figure this out before I go crazy! Electrical is not my forté.

Sent from my LG-D800 using Mustang Evolution mobile app
mattski is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-29-2014, 08:42 AM   #2
Registered Member
Regular
 
rollo1987's Avatar
 
Join Date: Jun 2014
Location: Fort Irwin
Region: California
Posts: 271
Electrical sucks. Now did you check the wiring just because the connections are tight dosnt mean that wire is good. U had an issue just the other day on a hummer not charging. Battery was good Alternator pushing out right voltage. It came out to be a wire they burned out. Repaired wire it was good. Also check your belts. If they are slipping the alternator won't push out enough volts to charge the battery. Those are what I would check. I know for sure others have differnt things. Good luck man.


Sent from my iPhone using Mustang Evolution
rollo1987 is offline   Reply With Quote
Old 08-29-2014, 08:59 AM   #3
Registered Member
Regular
 
rollo1987's Avatar
 
Join Date: Jun 2014
Location: Fort Irwin
Region: California
Posts: 271
Electrical sucks. Now did you check the wiring just because the connections are tight dosnt mean that wire is good. U had an issue just the other day on a hummer not charging. Battery was good Alternator pushing out right voltage. It came out to be a wire they burned out. Repaired wire it was good. Also check your belts. If they are slipping the alternator won't push out enough volts to charge the battery. Those are what I would check. I know for sure others have differnt things. Good luck man.


Sent from my iPhone using Mustang Evolution
rollo1987 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-29-2014, 11:01 AM   #4
Registered Member
Regular
 
mattski's Avatar
 
Join Date: May 2014
Location: CO Springs
Posts: 29
Belts tight. Continuity through the wires seems good. Just can't seem to find the fusible link. Anyone got a picture of their alternator wiring and how it's run? Because when I pulled the motor to rebuild it I didn't really take any mental notes on the wire placement

Sent from my LG-D800 using Mustang Evolution mobile app
mattski is offline   Reply With Quote
Old 08-29-2014, 11:24 AM   #5
Registered Member
Regular
 
rollo1987's Avatar
 
Join Date: Jun 2014
Location: Fort Irwin
Region: California
Posts: 271
I would send u one but my car is in the shop right not. Sorry


Sent from my iPhone using Mustang Evolution
rollo1987 is offline   Reply With Quote
Old 08-29-2014, 11:27 AM   #6
Registered Member
Regular
 
rollo1987's Avatar
 
Join Date: Jun 2014
Location: Fort Irwin
Region: California
Posts: 271
Another thing. Just because the belts are tight dosnt mean they are good. I had to change belts before. They were tight. But under the belts were.l very shinny telling me they were slipping. Causing the alternator not to charge. Let's hope it's something simple. It sucks you do all the work and found out some easy and cheap or free could fix it lol.


Sent from my iPhone using Mustang Evolution
rollo1987 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Charging System Problems 2 Stangz 2005-2010 Mustang GT 3 02-04-2014 10:55 PM
Apple stores to begin charging admission: MarkuzLS1 The Bar 11 07-28-2007 02:32 AM
charging system woes Thomas91169 Mustang Audio & Video 15 08-12-2006 01:34 AM
PLEASE Help!! charging issues...91 GT scorpionSStang 1979-1995 Mustang GT 11 02-10-2006 05:56 PM
battery charging problem I_luv_HP&trq Pre-2005 V6 Mustang 20 09-24-2005 03:58 AM

» Like Us On Facebook



09:54 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.