4.6l question - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-08-2014, 05:28 PM   #1
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
4.6l question

Any idea what fuel pressure is for my 4.7l?Click image for larger version

Name:	ImageUploadedByMustang Evolution1412807098.478004.jpg
Views:	276
Size:	764.0 KB
ID:	167601


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-08-2014, 07:17 PM   #2
Registered Member
Regular
 
thyreaper's Avatar
 
Join Date: Apr 2014
Posts: 328
Should be between 40-45 under a load (when vacuum drops) if u have the return style fuel system then pull the vacuum hose off the regulator and see/set the pressure


Sent from my iPhone using Mustang Evolution
thyreaper is offline   Reply With Quote
Old 10-08-2014, 10:04 PM   #3
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Ok I'll try that.. It acts like it's not getting quite enough fuel while at idle and driving, then once I get it up in rpm and speed, it runs fast and great.. But it has stock chrome fuel rails on it, and with tune, per sct, I'm not sure if it's an issue due to fuel rails, or if it's just not getting good delivery..


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-08-2014, 10:05 PM   #4
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Where do I find the regulator? Any ideas? Lol


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-10-2014, 04:20 PM   #5
Registered Member
Regular
 
thyreaper's Avatar
 
Join Date: Apr 2014
Posts: 328
What yr is ur car? U might have a returnless system with a press sensor instead the year of ur car will answer that one for me


Sent from my iPhone using Mustang Evolution
thyreaper is offline   Reply With Quote
Old 10-10-2014, 07:50 PM   #6
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
I traded my jeep for it.. And was told that it started out of factory as a 94 mustang gt, 5.0l, automatic.. then a previous owner got another mustang gt, with a 4.6l, that was supposedly a 99, and swapped everything out and added some bolt ons, so I was told that it has a 94 body and rear end, with newer 99 mustang gt everything else..


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-10-2014, 11:16 PM   #7
Registered Member
Regular
 
thyreaper's Avatar
 
Join Date: Apr 2014
Posts: 328
Well if the fuel system is from a 99 to then u have the returnless style system and dont have a fpr u have a fuel press sensor and only 1 fuel line but if u take a pic of the fuel rail up close on the left and right sides i can tell u for sure, cuz ur situation is alil confusing


Sent from my iPhone using Mustang Evolution
thyreaper is offline   Reply With Quote
Old 10-11-2014, 11:22 AM   #8
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Very confusing.. Lol. Ok I'll snap a couple pics


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-11-2014, 06:43 PM   #9
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Click image for larger version

Name:	ImageUploadedByMustang Evolution1413070855.222242.jpg
Views:	222
Size:	856.5 KB
ID:	167742Click image for larger version

Name:	ImageUploadedByMustang Evolution1413070877.260426.jpg
Views:	226
Size:	839.9 KB
ID:	167743Click image for larger version

Name:	ImageUploadedByMustang Evolution1413070916.042977.jpg
Views:	203
Size:	802.0 KB
ID:	167744Click image for larger version

Name:	ImageUploadedByMustang Evolution1413070941.270284.jpg
Views:	190
Size:	784.0 KB
ID:	167745Click image for larger version

Name:	ImageUploadedByMustang Evolution1413070964.015000.jpg
Views:	197
Size:	789.6 KB
ID:	167746Click image for larger version

Name:	ImageUploadedByMustang Evolution1413070988.405289.jpg
Views:	210
Size:	736.7 KB
ID:	167747


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-11-2014, 06:51 PM   #10
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Could misfiring cause lots of back fire? Gearing down my car also sounds like it's popping pop corn.. Lol I'm still thinking that a good bit of my issues is coming from my COP's..:/


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-11-2014, 11:53 PM   #11
Registered Member
Regular
 
Join Date: Sep 2010
Posts: 128
The last picture has your FRPS in it. Fuel Rail Pressure Sensor. Looks like you have Accel COP.
Complete garbage. I'm not saying they are the problem but OEM is really the only way to go.
Are you throwing any codes? Does the MIL light blink when you are having the popping noises?
If you have an SCT tuner and a laptop you can data log and get to the bottom of it real quickly.

Popping on deceleration usually means unburned fuel or fumes in the exhaust system. Can be emissions problem, timing too far advanced, exhaust manifold leak or a host of other problems.
Check for codes first, monitor fuel pressure and start from there,
vert03 is offline   Reply With Quote
Old 10-12-2014, 10:43 AM   #12
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
No codes, and I've only tried once at data logging with my sct.. am I supposed to turn in data logging and just start my car, or drive it? then when I figure that out, how can I view it with my laptop? I have a program on my laptop that I downloaded from the sct site, but it's to update it, and I didn't see an option for data logging.. They say it can be tough to figure out at first, but once you do it's the easiest and quickest/best way to figure a more defined tune.. I'm probly just thinking too hard about it..


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-12-2014, 02:46 PM   #13
Registered Member
Regular
 
Join Date: Sep 2010
Posts: 128
https://support.lundracing.com/hc/en...to-Datalog-SCT

Should get you started. It's important to connect the tuner and laptop in the correct order or it won't work.
I forget what the order is

Check the SCT site for their instructions as well.

Basically create a file of what you want to log, the Lund site has a good list, save it, hook up the tuner/laptop and and then start the program using the file you created with the parameters you want to log.

Drive around and try and aggravate the symptoms. IOW make it fail.
Once you have a failure, pull over, stop the laptop, save the session and go home. Disconnect everything, open the software on the laptop and play it back until you get to the failure then look and see what's happening.

IOW:
Did fuel pressure drop when it failed?
Were you logging misfires?
Anything that looks different at the time of the failure is suspect, even if you don't know exactly what you are seeing.

Post back any results and the people here can help interpret the log.

It's really easier than it sounds.
Just resist playing with the laptop when you are driving and make sure to route the cables so you don't get your feet tangled in them.
vert03 is offline   Reply With Quote
Old 10-12-2014, 03:23 PM   #14
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
I ended up you tuning it, I logged misfires for all 8 cylinders twice, first run popped up a spike for cylinder 8, the second run popped up a spike for cylinder 4..


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-12-2014, 04:23 PM   #15
Registered Member
Regular
 
pjtavish's Avatar
 
Join Date: Oct 2014
Location: California
Region: California
Posts: 24
Those accel coils are crap man. I ran those coils for about 3 mins and pulled multiple misfires on all 8 cyl. Exchanged them and went with the MSD coils. Great coils!


Sent from my iPhone using Mustang Evolution
pjtavish is offline   Reply With Quote
Old 10-12-2014, 07:23 PM   #16
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Ya I just done another run, and it was misfire on cylinder 6 and cylinder 8..


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-12-2014, 07:24 PM   #17
Registered Member
Regular
 
thyreaper's Avatar
 
Join Date: Apr 2014
Posts: 328
Yea thats looking like its more of a random misfire if its happening on different cylinders each time, get you some Oem COP's and dont mess with the aftermarket ones and if cost is an issue try your locL salvage yard ( even tho i really dont rec used electrical like that but even those will be better then the aftermarket ones lol) but also try cleaning your MAF sensor while ur at it and run some ngk plugs or ford plugs nothing else if your still misfiring after all that then look for a intake/ vacuum leak then if all else fails check your compression but these motors usually are pretty strong in there stock/ lightly modded form so i dont usually see drop'd compression but it does happen


Sent from my iPhone using Mustang Evolution
thyreaper is offline   Reply With Quote
Old 10-12-2014, 07:28 PM   #18
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
4.6l question

Click image for larger version

Name:	ImageUploadedByMustang Evolution1413160012.878759.jpg
Views:	144
Size:	221.4 KB
ID:	167776 so even these would be better? Scared cause of the low price, however the accels are expensive and crap, so maybe "you get what you pay for" don't apply too much in this area.. Lol
These ones might be cheap, but they have a lot of good ratings from others that have purchased them..

Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-12-2014, 07:31 PM   #19
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Is the computer easy to get too? I'm used to one being under the hood, but can't find one there.. I'm wondering also if there's a chip plugged I to the computer, and if I'm having a battle of the chip vs sct, after reading more on sct, it states not to have any other chips or tunes while using sct..


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-12-2014, 07:35 PM   #20
Registered Member
Regular
 
thyreaper's Avatar
 
Join Date: Apr 2014
Posts: 328
Yea sort of the computer is inside on the lower passenger kickpanel and id go oem ford for the cop no since in wasting money on anything else


Sent from my iPhone using Mustang Evolution
thyreaper is offline   Reply With Quote
Old 10-12-2014, 07:45 PM   #21
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Ok, I'll check the computer tomorrow, just in case there is a JET performance chip for example shoved in it.. Lol


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-12-2014, 07:55 PM   #22
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Quote:
Originally Posted by thyreaper View Post
Yea sort of the computer is inside on the lower passenger kickpanel and id go oem ford for the cop no since in wasting money on anything else


Sent from my iPhone using Mustang Evolution

Ok, I'll check the computer tomorrow, just in case there is a JET performance chip for example shoved in it.. Lol


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-12-2014, 08:03 PM   #23
Registered Member
Regular
 
thyreaper's Avatar
 
Join Date: Apr 2014
Posts: 328
Yea i had one in mine and put in a canned tune from AM with it in there and to my suprise the sct handheld was still able to load the tune with the chip i bet my computer didnt know what to do lol


Sent from my iPhone using Mustang Evolution
thyreaper is offline   Reply With Quote
Old 10-12-2014, 08:47 PM   #24
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Ya and I'm just not sure, I wasn't told very much about this mustang, the only thing the guy I got it from did to it, was put a new clutch in it.. I do know by looking at it tho that it has no cats, no rear o2's, then all the visible aftermarket on the motor.. Even PI upgrade I believe, but the COP's are a bummer..


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-12-2014, 09:05 PM   #25
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Click image for larger version

Name:	ImageUploadedByMustang Evolution1413165854.824579.jpg
Views:	135
Size:	756.5 KB
ID:	167782Click image for larger version

Name:	ImageUploadedByMustang Evolution1413165876.614901.jpg
Views:	131
Size:	835.3 KB
ID:	167783Click image for larger version

Name:	ImageUploadedByMustang Evolution1413165896.716126.jpg
Views:	138
Size:	1.13 MB
ID:	167784


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-17-2014, 11:48 PM   #26
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Pulled my computer today, and there's no chip in it.. So it's not that being an issue.. Lol I'm gonna clean my MAF tomorrow, see if that helps.. Lol


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-18-2014, 09:25 AM   #27
Registered Member
Regular
 
Join Date: Sep 2010
Posts: 128
Cylinder 6 and 8 are sick. Very sick

Move the COP from cylinder 6+8 to another cylinder, data log again and see if the misfires move with the COP. While you are at it check the spark plugs as well.

You can get the boot kit on Rock Auto for about the same price.
It's a high quality kit.

Also check the harness that runs along the firewall. It runs right by the EGR valve and if the tie wrap breaks it will lean against the EGR and melt the wires. I had this happen and it blew out 2 COP on my car before I figured out what was wrong.
vert03 is offline   Reply With Quote
Old 10-18-2014, 12:13 PM   #28
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
The run I did before the one that's pictured, said bad for cylinder 4 and 8.. Then the ones in the picture are 6 and 8.. Just confuses the **** out of me..


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-18-2014, 01:22 PM   #29
Registered Member
Regular
 
Join Date: Sep 2010
Posts: 128
Misfire caused by COP can come and go depending upon weather, load and God only knows what else.
I had two bad COP a couple of months ago (not related to the shorted cable I posted about) and while the logging did show occasional misfires on other cylinders, the two bad ones had many. many more hits.

If it were me, I would get those Accel COP out of there, make sure you running the factory tune and maybe toss some NGK or Motorcraft plugs in at the same time.

You need to set a baseline and then trouble shoot from there.

Otherwise you are going to drive yourself crazy
vert03 is offline   Reply With Quote
Old 10-18-2014, 03:58 PM   #30
WJL
Registered Member
Regular
 
Join Date: Jan 2014
Location: Pittsburgh
Region: Pennsylvania
Posts: 285
From looking at the pictures you have pink injectors and orange injectors the pink ones 21 #/hr and the orange are 19 #/hr. just an observation. So if your going to the junk yard look for some injectors as well. different injector rates could cause problems
WJL is offline   Reply With Quote
Old 10-18-2014, 04:20 PM   #31
Registered Member
Regular
 
thyreaper's Avatar
 
Join Date: Apr 2014
Posts: 328
Quote:
Originally Posted by WJL View Post
From looking at the pictures you have pink injectors and orange injectors the pink ones 21 #/hr and the orange are 19 #/hr. just an observation. So if your going to the junk yard look for some injectors as well. different injector rates could cause problems

He is right thats a good observation you have different injectors that could also be causing the different misfires as well as those crappy cop's. I actually think i have a set of 19/lb orange ones that ill give u just pay shipping u absolutely need them to all be of the right kind


Sent from my iPhone using Mustang Evolution
thyreaper is offline   Reply With Quote
Old 10-18-2014, 04:58 PM   #32
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
Lol how would I pay shipping?


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-18-2014, 05:00 PM   #33
Registered Member
Regular
 
johnathan2225's Avatar
 
Join Date: Oct 2014
Location: Clarksburg/Salem
Region: West Virgina
Posts: 166
4.6l question

Today's data log.. About a regular 25-30 min drive, but done it in around 12 min.. LolClick image for larger version

Name:	ImageUploadedByMustang Evolution1413669589.614267.jpg
Views:	98
Size:	705.7 KB
ID:	168057Click image for larger version

Name:	ImageUploadedByMustang Evolution1413669609.374922.jpg
Views:	96
Size:	1.29 MB
ID:	168058


Sent from my iPhone using Mustang Evolution
__________________
5.0l auto, swapped out with 4.6l 5 speed, summit cold air, 17"saleen, cat delete, rear o2 delete, H-pipe, 94 body and rear end, 99 everything else..
johnathan2225 is offline   Reply With Quote
Old 10-18-2014, 05:41 PM   #34
Registered Member
Regular
 
thyreaper's Avatar
 
Join Date: Apr 2014
Posts: 328
Quote:
Originally Posted by johnathan2225 View Post
Lol how would I pay shipping?


Sent from my iPhone using Mustang Evolution

Paypal?


Sent from my iPhone using Mustang Evolution
thyreaper is offline   Reply With Quote
Old 10-18-2014, 05:48 PM   #35
Registered Member
Regular
 
thyreaper's Avatar
 
Join Date: Apr 2014
Posts: 328
Also count how many pink injectors u have and how many orange or yellow injectors u have u need to make them all the same ur fuel trims i bet are soo wackd that ur car dont know what to do some of ur cylinders are running pig rich and some are like they should


Sent from my iPhone using Mustang Evolution
thyreaper is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question question!?!? AmericanBulldog Pre-2005 V6 Mustang 11 12-11-2013 09:24 PM
Wheel gap question and lca question Mdazi 2011-2014 Mustang GT 27 05-27-2013 08:11 PM
Wheel Question / possibly stupid question Rogue Slider Mustang Wheels & Tires 8 05-29-2012 01:21 PM
Question: I would like to know from you guys (See background and full question)? dumont75 General Mustang Discussion 16 03-03-2010 07:17 PM
Car question? Duh, of course it's a car question, silly!? imported_daman General Car Discussion 3 08-17-2009 07:40 PM

» Like Us On Facebook



08:15 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.