Abs and traction control light - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-17-2014, 06:30 PM   #1
Registered Member
Regular
 
Yellastang03's Avatar
 
Join Date: Sep 2014
Location: South Elgin
Region: Illinois
Posts: 46
Abs and traction control light

Lately my traction control light and abs light will kick on for about 5 seconds and then go away about every 10 miles or so for no reason with no true spin what so ever. Under completely normal driving conditions. Anyone ever heard or experienced this? 2003 gt.


Sent from my iPhone using Mustang Evolution

---------- Post added at 05:30 PM ---------- Previous post was at 05:29 PM ----------

With no tire spin*


Sent from my iPhone using Mustang Evolution
Yellastang03 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-17-2014, 07:20 PM   #2
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,409
Do you mean that both the ABS and the "tire spinning" icon light up at the same time?

Do you have a staggered wheel setup on your car?
straybullitt is offline   Reply With Quote
Old 10-17-2014, 08:14 PM   #3
Registered Member
Regular
 
2stang's Avatar
 
Join Date: May 2013
Location: knoxville
Region: Tennessee
Posts: 196
could be as simple as wheel sensors getting brake dust buildup and need cleaning, or control unit could be malfunctioning, check and clean abs sensors and connections, also may want to clean control unit connection, intermittent problems can be a pain to track down,
2stang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-17-2014, 08:24 PM   #4
Registered Member
Regular
 
Yellastang03's Avatar
 
Join Date: Sep 2014
Location: South Elgin
Region: Illinois
Posts: 46
I mean both the abs light and the loss of traction light. And also have the stock square set up. Yeah I'll run through all the abs sensors to see how they look. Just thought it was really odd.


Sent from my iPhone using Mustang Evolution
Yellastang03 is offline   Reply With Quote
Old 10-17-2014, 08:40 PM   #5
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,409
It is odd!
Mine went berserk like that right before it stopped working completely.
The "spinning tire" would stay lit up with the car at a dead stop.
straybullitt is offline   Reply With Quote
Old 10-18-2014, 09:33 AM   #6
Registered Member
Regular
 
Join Date: Sep 2010
Posts: 128
Like 2stang says, dirt on the sensors. They pick up metallic particles and get a metallic "fuzz" on them which screws up the signal pulses back to the computer. Clean them and also check for frayed wires around the sensor or connector.
vert03 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS light + traction control doesnt work RedGT04 1996-2004 Mustang GT 16 11-12-2015 07:43 PM
ABS light on and Traction Control off Constantine 1996-2004 Mustang GT 16 11-14-2013 06:43 AM
ABS & Traction Control light ON!!! Stryker01 2005-2010 V6 Mustang 3 02-22-2013 09:31 PM
Different Tire Size and Traction Control/ ABS Issues TimeMachine 2011-2014 Mustang GT 17 07-05-2012 12:08 AM
ABS and Traction control light on rugman1969 1996-2004 Mustang GT 1 09-30-2006 04:09 PM

» Like Us On Facebook



12:53 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.