Instrument Cluster malfunctioning - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-25-2014, 06:34 AM   #1
Registered Member
Regular
 
99_GRUMPY_GT's Avatar
 
Join Date: Aug 2014
Location: Cabo Rojo, P.R.
Region: Other
Posts: 590
Instrument Cluster malfunctioning

Yesterday I was driving home when I noticed that the battery and ABS dummy lights were coming on, the battery light stayed constantly on, but the ABS was blicking every few seconds. Now I know these two lights have nothing to do with the problem but that of a result of my problem.

My cluster and all its guages are malfunctioning. First it started with the battery gauge pegging far right when I accelerated through the gears and then would go back to normal when RPMS are going down from slowing down. And when the RPMS are rising, the aux. components would rise like the A/C, the A/C would blow harder when the battery gauge would peg. Last night the low beams would get ultra high when accelerating. Then the other guages like the tach and speedo would either not move and when they do not move during acceration, they would peg far right during slowing down with no accelerator action, then go back to zero. The gas and oil and temp guages do the same.

Any ideas as to what is causing this mishap?

The alternator was just replaced last month. And there is no CEL to identify this fault.

Thanks
__________________


2015 Race Red Performance Package GT 5.0 (435hp) stock
Still in the making Updates coming soon!
99_GRUMPY_GT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-25-2014, 10:38 AM   #2
Registered Member
Regular
 
99_GRUMPY_GT's Avatar
 
Join Date: Aug 2014
Location: Cabo Rojo, P.R.
Region: Other
Posts: 590
Well I checked all fuses and all good. Battery after running around town started to leak fluid from caps and was smoking.

So that told me the brand new alternator was over charging and bad. So I went back to Pep Boys and they hooked up to the battery, which tested good, then the alternator and as I thought tested bad. So they are swapping it out now.

Good thing I saw the battery acid and smoke or much longer and it could of been a messy situation for sure or even worse exploded while I was under the hood and severely hurt myself.

Sent from my LG-D415 using Mustang Evolution mobile app
__________________


2015 Race Red Performance Package GT 5.0 (435hp) stock
Still in the making Updates coming soon!
99_GRUMPY_GT is offline   Reply With Quote
Old 11-25-2014, 01:39 PM   #3
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,415
Where have you been Bill?
I hope that you've been doing well, aside from the alternator.


I had this very same thing happen years ago. My alternator was overcharging and it slowly boiled down the water level to the point where too much hydrogen built up inside of the battery and when I went to start it one time... BOOM!!! The battery exploded! Lol. It actually dented the hood on my truck!

Good to hear from you again and glad you caught the problem in time!
straybullitt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-25-2014, 03:48 PM   #4
Registered Member
Regular
 
99_GRUMPY_GT's Avatar
 
Join Date: Aug 2014
Location: Cabo Rojo, P.R.
Region: Other
Posts: 590
I am doing fine. A while back i started my own business after total boredom set in with my retirement. It took off like nothing I ever expected. I actually had to hire a individual to help keep up with all the work. I may even have to hire another soon. I try to drop in when time allows. Good to hear from you Ron.

Sent from my LG-D415 using Mustang Evolution mobile app
__________________


2015 Race Red Performance Package GT 5.0 (435hp) stock
Still in the making Updates coming soon!
99_GRUMPY_GT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Roush Mustang Instrument Cluster BetsyBootstrap Pre-2005 V6 Mustang 3 06-30-2010 01:08 PM
Brake, ABS & Instrument Cluster stevinas 2005-2010 Mustang GT 4 07-01-2008 09:53 AM
Need help on Instrument cluster. Batroo 1979-1995 Mustang GT 4 04-23-2008 10:48 PM
instrument cluster swap pipeguy General Mustang Discussion 0 04-11-2008 10:43 AM
94 - 95 GT Instrument Cluster StreetRacer4371 Mustang Parts for Sale and Wanted 5 10-21-2004 09:32 PM

» Like Us On Facebook



11:22 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.