Converible help! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-22-2014, 05:33 PM   #1
Registered Member
Regular
 
Jay180's Avatar
 
Join Date: Sep 2014
Location: Phoenix
Region: Arizona
Posts: 157
Converible help!

So I put transmission fluid (Mercon V) in my convertible motor and everything was working fine. The top went up and down as it should, then I put my seats back in and tried to put my top up and it doesn't go up. There's no noise or anything at all it won't go up. E-brake light is on as well.
Jay180 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-22-2014, 05:47 PM   #2
Registered Member
Regular
 
yellowconve's Avatar
 
Join Date: Jan 2014
Location: laredo
Region: Texas
Posts: 615
check the fuses if not i would suggest get a volt meter and check the switch to see if that is it.
yellowconve is offline   Reply With Quote
Old 12-23-2014, 07:51 AM   #3
Registered Member
Regular
 
runvsofthisbull's Avatar
 
Join Date: Jul 2006
Region: Florida
Posts: 606
Might be a dumb question but when you refilled the pump did you disconnect the harnesses? If you don't here anything (the pump cycling the lift cylinders) this could be the issue.
__________________

2002 True Blue V6 to GT Vert
16.1@86 as an auto 3.8
2.15 60', 9.3@77, 14.4@96 as a 5spd SOHC 4.6
runvsofthisbull is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-27-2014, 01:03 PM   #4
Registered Member
Regular
 
Jay180's Avatar
 
Join Date: Sep 2014
Location: Phoenix
Region: Arizona
Posts: 157
No I didn't disconnect anything
Jay180 is offline   Reply With Quote
Old 12-27-2014, 01:35 PM   #5
Registered Member
Regular
 
GrabberMeBlue's Avatar
 
Join Date: Jul 2013
Location: Somewhere
Region: Wisconsin
Posts: 1,710
Converible help!

Quote:
Originally Posted by Jay180 View Post
So I put transmission fluid (Mercon V) in my convertible motor and everything was working fine. The top went up and down as it should, then I put my seats back in and tried to put my top up and it doesn't go up. There's no noise or anything at all it won't go up. E-brake light is on as well.

Take your seats back out. Does it work again?


2012 Grabber Blue Mustang Convertible V6 Premium
1979 Solar Gold Trans Am
1995 Bright Red Trans Am Convertible
__________________
2012 Grabber Blue V6 Convertible
1995 Red Trans Am Convertible
1979 Gold Trans Am
GrabberMeBlue is offline   Reply With Quote
Old 12-30-2014, 07:19 PM   #6
Registered Member
Regular
 
Jay180's Avatar
 
Join Date: Sep 2014
Location: Phoenix
Region: Arizona
Posts: 157
Well it works now, somewhat when it wants to. But it doesn't fit right. It bends inward when it's all the way up
Jay180 is offline   Reply With Quote
Old 01-02-2015, 06:17 AM   #7
Registered Member
Regular
 
runvsofthisbull's Avatar
 
Join Date: Jul 2006
Region: Florida
Posts: 606
Is the fluid leaking from the lift cylinders? Do you have any fluid either under the rear seat or on the floor (sometimes one just goes bad)? If one side goes up faster than another it could be because one of them is going bad and doesn't have the correct pressure due to a leak. I replaced both of mine about a year ago since the top stopped going up do to one leaking badly (the o rings just give out after 5-10 years). If either of the lines are kinked that would cause it too. Lastly is the pump grommet back in? I know that thing is a PITA and it likes to pop out.
__________________

2002 True Blue V6 to GT Vert
16.1@86 as an auto 3.8
2.15 60', 9.3@77, 14.4@96 as a 5spd SOHC 4.6
runvsofthisbull is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Help Help....mustang Princehollie Pre-2005 V6 Mustang 57 03-17-2015 05:58 PM
Help Help Help....1995 mustang 3.8 Princehollie Pre-2005 V6 Mustang 4 07-03-2014 07:42 PM
Baltimore area spark plug insert!! Help Help HELP readytorockyou 1996-2004 Mustang GT 0 04-25-2010 12:37 PM
Help help- fuel pump-help! The Darkside Pre-2005 V6 Mustang 26 05-08-2009 02:45 PM
Help help help? Seph Mustang Audio & Video 6 02-15-2004 05:35 PM

» Like Us On Facebook



09:23 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.