Compression test results concerning and issues after build - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-12-2015, 12:07 AM   #1
Registered User
Newbie
 
Join Date: Feb 2015
Posts: 3
Compression test results concerning and issues after build

In short, I just finished putting in CMS stage 3 blower cams and max lift valve springs, timing chain slipped and I didn't realize it and bent some valves. I took my heads off had them ported polished valves redone and a valve job. I put everything back together with all new gaskets and bolts and tried to start the car but it just cranked and didn't start. My spark plugs are not sparking. I checked all fuses, replaced crankshaft position sensor, and still nothing. Any ideas on what that could be? Also I checked my compression and all cylinders were between 75 and 85 does this seem right with my set up? I've never checked the compressing when it was running so I have no idea what it was before adding the cams. This set up has about 2500 miles on it. I have a 2002 4.6 2v stroked to a 5.0 with forged Manley internals 8:1 compression ratio, stage 3 cms blower cams, vortech v1 15psi pulley, and ported and polished stock pi heads heads. I have ran this set up with no issues for a while and except with stock cams and a 10 psi pulley.

Sent from my SAMSUNG-SM-N900A using Mustang Evolution mobile app
taylorboy54 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-13-2015, 01:13 AM   #2
Registered User
Newbie
 
Join Date: Feb 2015
Posts: 3
Just wanted to update everyone. I did a wire tuck during this build and one of my connectors in the fender was loose. I connected it completely and the car fired right up and sounds amazing. I have not checked the CR yet to see if it has raised since I got it running.

Sent from my SAMSUNG-SM-N900A using Mustang Evolution mobile app
taylorboy54 is offline   Reply With Quote
Old 02-13-2015, 01:15 AM   #3
Registered Member

Regular
 
Recon's Avatar
 
Join Date: Jan 2015
Location: Hopkinsville
Region: Kentucky
Posts: 6,515
Good to hear it's fixed. Now post a video and let's hear that cam!


Adventure till you drop
__________________
Mustangalley.com
Mustang of the day,
July 12, 2015
Recon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-13-2015, 02:14 AM   #4
Registered Member
Regular
 
Join Date: Aug 2012
Region: California
Posts: 53
Quote:
Originally Posted by taylorboy54 View Post
Just wanted to update everyone. I did a wire tuck during this build and one of my connectors in the fender was loose. I connected it completely and the car fired right up and sounds amazing. I have not checked the CR yet to see if it has raised since I got it running.

Sent from my SAMSUNG-SM-N900A using Mustang Evolution mobile app
Can i get a pic of the wire tuck if you dont mind

Sent from my SM-G900V using Mustang Evolution mobile app
clinesr22 is offline   Reply With Quote
Old 02-13-2015, 09:05 AM   #5
Registered User
Newbie
 
Join Date: Feb 2015
Posts: 3
Yes I will get a pic posted and a video of it running today.

Sent from my SAMSUNG-SM-N900A using Mustang Evolution mobile app
taylorboy54 is offline   Reply With Quote
Old 02-13-2015, 01:13 PM   #6
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,411
When you did the compression test, did you pin the throttle body in the wide open position?

That could account for the low compression readings...
straybullitt is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compression spec test Tork6 1979-1995 Mustang GT 2 04-16-2013 06:02 PM
Compression test Gmkiller 1979-1995 Mustang GT 1 12-26-2012 05:45 AM
Mach 1 compression test? MachMan1017 General Mustang Discussion 1 09-04-2012 11:30 PM
Compression test... Mathew r Wright 1996-2004 Mustang GT 2 03-08-2012 03:40 PM
Mustang Wheels and Tires FAQ: Come here for questions concerning tire size!! Zim Mustang Wheels & Tires 24 12-25-2010 11:55 PM

» Like Us On Facebook



02:32 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.