Turn Signals, Brake Lights, and Hazards are not working. - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-25-2015, 07:41 AM   #1
Registered User
Newbie
 
Join Date: Jan 2015
Posts: 8
Turn Signals, Brake Lights, and Hazards are not working.

I have an 04 GT with 25,000 miles. The turn signals and brake lights stopped working all of the sudden a few weeks ago. I checked the fuses, 3 blew out. Numbers 13, 33, and 41. They are all 15 amp. I replaced them and tried the turn signals again, it worked for one click on the left side and blew the fuse again. I figured it was the multifunction switch because this is a common problem from what i understand. I installed the new switch, replaced the 3 fuses and tried the turn signals, brake lights, and hazards and non of them worked at all, but this time it didn't blow any fuses. I checked the connectors on the tail lights everything seems to be fine. I don't know what else to do other than to take it to a shop. Any suggestions?
Rusty_Surf90 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-25-2015, 07:51 AM   #2
Registered Member
Regular
 
69mach1390's Avatar
 
Join Date: Aug 2013
Location: Winston Salem
Region: North Carolina
Posts: 68
It's the hazard switch went bad I had the same problem with a 03 mach 1. There all wired together


Sent from my iPhone using Mustang Evolution
69mach1390 is offline   Reply With Quote
Old 04-25-2015, 07:55 AM   #3
Registered User
Newbie
 
Join Date: Jan 2015
Posts: 8
isn't the hazard switch on the multifunction switch that i replaced?
Rusty_Surf90 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-25-2015, 08:33 AM   #4
Registered Member
Regular
 
69mach1390's Avatar
 
Join Date: Aug 2013
Location: Winston Salem
Region: North Carolina
Posts: 68
Ok if u have replaced that. It could be the flasher relay


Sent from my iPhone using Mustang Evolution
69mach1390 is offline   Reply With Quote
Old 04-25-2015, 08:41 AM   #5
Registered User
Newbie
 
Join Date: Jan 2015
Posts: 8
Where is that located? I forgot to mention that i have a raxiom flasher modifier. I put the stock one back in to see if that worked but it didn't.
Rusty_Surf90 is offline   Reply With Quote
Old 04-25-2015, 06:51 PM   #6
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
The flasher modifier is the relay he's talking about. I believe it's the one one near your right knee when sitting in the driver seat.

Sent from the Death Star.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 04-26-2015, 04:39 PM   #7
Registered Member
Regular
 
robb15033's Avatar
 
Join Date: Oct 2010
Location: Northern Virginia
Region: Virginia
Posts: 2,109
Above your left knee is where the turn signal relay. When mine is not plugged in all the way, No turns, brake, and hazards.
-Happened 3 days ago.
Good luck
__________________
'97 3.8L V6
Pacific Green
1996 SVT Cobra White
robb15033 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wipers/Turn signals not working. Bford024 1979-1995 Mustang GT 2 03-12-2014 05:19 PM
flasher fuse blows and no brake lights/turn signals CCSOdeputy 1996-2004 Mustang GT 7 08-18-2013 01:11 PM
No hazards lights - ideas? 6805stang Classic Mustangs 12 09-30-2012 08:19 PM
Turn Signals Not Working irving91605 Pre-2005 V6 Mustang 18 06-15-2012 12:55 PM
Turn signals and breaklights not working Genocide 99gt 1996-2004 Mustang GT 10 01-30-2012 01:18 AM

» Like Us On Facebook



12:18 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.