Service engine soon light - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-04-2015, 12:42 PM   #1
Registered Member
Regular
 
Join Date: Mar 2015
Posts: 252
Service engine soon light

So my service engine light came on today while on a short ride. No lagging, spitting or any other noticeable issue. She is running and idling like a top. Any ideas? Not too keen to bring her into the shop if I don't have to.

Sent from my SCH-I545 using Mustang Evolution mobile app
Vinnie02 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-04-2015, 12:45 PM   #2
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
Take it by AutoZone and get codes ran
natestang07 is offline   Reply With Quote
Old 05-04-2015, 12:55 PM   #3
Registered Member
Regular
 
Join Date: Mar 2015
Posts: 252
I didn't know that they did that....thanks for the info.

Sent from my SCH-I545 using Mustang Evolution mobile app
Vinnie02 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-04-2015, 01:29 PM   #4
Registered Member
Regular
 
Dub9stang's Avatar
 
Join Date: Oct 2012
Location: Chicagoland
Region: Illinois
Posts: 278
Quote:
Originally Posted by Vinnie02 View Post
I didn't know that they did that....thanks for the info.

Sent from my SCH-I545 using Mustang Evolution mobile app

Yea they will print out a code along with the top causes for the code. If you got no drivability issues hopefully its something as simple as a loose fuel cap
Dub9stang is offline   Reply With Quote
Old 05-04-2015, 01:51 PM   #5
Registered Member
Regular
 
keeney35's Avatar
 
Join Date: Jan 2015
Location: Poplar Bluff
Region: Missouri
Posts: 1,128
I drive with mine on constantly for having no cats, but hopefully it's just something simple like a sensor
keeney35 is offline   Reply With Quote
Old 05-05-2015, 08:47 AM   #6
Registered Member
Regular
 
Join Date: Mar 2015
Posts: 252
Went to advance auto to have the code read and it said O2 sensor 1 bank 2 lean condition. Then they cleared the code. So I will have to take care of that at a later time. Is that the sensor before or after the cats?

Sent from my SCH-I545 using Mustang Evolution mobile app
Vinnie02 is offline   Reply With Quote
Old 05-05-2015, 01:32 PM   #7
Registered User
Newbie
 
boostedhog88's Avatar
 
Join Date: Apr 2015
Location: Fayetteville
Region: Arkansas
Posts: 15
Driver's side behind the cat.
__________________
"My car is too fast" - No car guy ever
boostedhog88 is offline   Reply With Quote
Old 05-05-2015, 01:58 PM   #8
Registered Member
Regular
 
Join Date: Mar 2015
Posts: 252
Thanks boosted.

Sent from my SCH-I545 using Mustang Evolution mobile app
Vinnie02 is offline   Reply With Quote
Old 05-05-2015, 04:12 PM   #9
Registered Member
Regular
 
Slater2111's Avatar
 
Join Date: Dec 2014
Location: Jacksonville
Region: Florida
Posts: 1,001
Im pretty sure he means drivers side pre cat oxygen sensor. Just to clear that up


Sent from the mothership.
Slater2111 is offline   Reply With Quote
Old 05-05-2015, 05:47 PM   #10
Registered User
Newbie
 
boostedhog88's Avatar
 
Join Date: Apr 2015
Location: Fayetteville
Region: Arkansas
Posts: 15
Quote:
Originally Posted by Slater2111 View Post
Im pretty sure he means drivers side pre cat oxygen sensor. Just to clear that up


Sent from the mothership.
Yeah I did, thats what i get for being on the forum during work
__________________
"My car is too fast" - No car guy ever
boostedhog88 is offline   Reply With Quote
Old 05-07-2015, 08:08 PM   #11
Registered Member
Regular
 
fenixignition's Avatar
 
Join Date: Nov 2014
Location: Clearwater, fl
Region: Florida
Posts: 1,050
yep. bank 1 is the side with cylinder 1, in our case, drivers side. sensor 2 is the second sensor down the line. post cat. also called downstream. upstream being sensor 1, pre cat.
__________________
2002 GT 5sp. 16x,xxx miles
Steeda Exhaust, C&L plenum, BBK Throttle Body, Steeda Underdrive, Steeda short throw, unknown stage clutch. Rear main leak. Compressor seal leak. Steeda lower control arms. good tires.
fenixignition is offline   Reply With Quote
Old 05-09-2015, 07:11 PM   #12
Registered Member
Regular
 
Join Date: Mar 2015
Posts: 252
Light came back on...but I already know its the o2 sensor. But it's reading a lean condition, does that mean I am having an injector problem?

Sent from my SCH-I545 using Mustang Evolution mobile app
Vinnie02 is offline   Reply With Quote
Old 05-18-2015, 08:03 AM   #13
Registered Member
Regular
 
Join Date: Mar 2015
Posts: 252
Figured out the issue...cai was loose after the MAF sensor. Will the code reset itself or do I have to have it cleared.

Sent from my SCH-I545 using Mustang Evolution mobile app
Vinnie02 is offline   Reply With Quote
Old 05-18-2015, 08:04 AM   #14
Registered Member
Regular
 
fenixignition's Avatar
 
Join Date: Nov 2014
Location: Clearwater, fl
Region: Florida
Posts: 1,050
I would get it cleared. But it may go away on its own after a certain number of miles.

Actually, I would do a battery pull so the ECU can relearn its idle and such, since it was an opening in the intake tubing.
__________________
2002 GT 5sp. 16x,xxx miles
Steeda Exhaust, C&L plenum, BBK Throttle Body, Steeda Underdrive, Steeda short throw, unknown stage clutch. Rear main leak. Compressor seal leak. Steeda lower control arms. good tires.
fenixignition is offline   Reply With Quote
Old 05-19-2015, 07:15 PM   #15
Registered Member
Regular
 
Panther140's Avatar
 
Join Date: Sep 2014
Location: xxx
Region: Other
Posts: 1,473
You probably know my take on this **** haha
Panther140 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Service Engine Soon light on WhiteStang99 Pre-2005 V6 Mustang 20 07-22-2015 09:42 PM
The Service Engine Light Soon light is on!! HELP! punisher0822 1996-2004 Mustang GT 11 07-15-2010 11:15 PM
Check Fuel Cap & Service Engine Soon Light??????? mattstang Pre-2005 V6 Mustang 8 12-25-2006 02:33 PM
service engine soon light (ugh) johnww Pre-2005 V6 Mustang 9 03-17-2005 06:39 PM
service engine soon light tek55 Pre-2005 V6 Mustang 4 11-13-2003 03:00 PM

» Like Us On Facebook



01:14 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.