Help please - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-07-2015, 09:38 PM   #1
Registered Member
Regular
 
code_cobra911's Avatar
 
Join Date: May 2014
Posts: 78
Help please

So I completed the 5.4 2v swap into my v6 and now I'm havin a little bit of a problem. I've lost a major amount of power. My motor seems like it's straining a bit and I keep having this loud bang under my car whenever I shift under high rpms. Also whenever I crank it something squeaks loud for like a second. It sounds like a bad belt squeak but it's not it's more under the car


Sent from my iPhone using Mustang Evolution
code_cobra911 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-07-2015, 09:40 PM   #2
Registered Member
Regular
 
code_cobra911's Avatar
 
Join Date: May 2014
Posts: 78
Also it's vibrating really bad when cruising


Sent from my iPhone using Mustang Evolution
code_cobra911 is offline   Reply With Quote
Old 05-07-2015, 09:42 PM   #3
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
Is your clutch toast?
natestang07 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-07-2015, 09:43 PM   #4
Registered Member
Regular
 
code_cobra911's Avatar
 
Join Date: May 2014
Posts: 78
No clutch is good it's brand new and I'm having no trouble with it


Sent from my iPhone using Mustang Evolution
code_cobra911 is offline   Reply With Quote
Old 05-07-2015, 09:45 PM   #5
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
So what all did you swap into the car?
natestang07 is offline   Reply With Quote
Old 05-07-2015, 09:46 PM   #6
Registered Member
Regular
 
code_cobra911's Avatar
 
Join Date: May 2014
Posts: 78
Motor stated, t-45 tranny, gt driveshaft, and a 7.5" rear end with welded spider gears. Not the best idea but I don't think that's the problem


Sent from my iPhone using Mustang Evolution
code_cobra911 is offline   Reply With Quote
Old 05-07-2015, 09:48 PM   #7
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
So I'm going to focus mostly on the power part of the issue since that is what I have a little knowledge on. What was the 5.4 out of?
natestang07 is offline   Reply With Quote
Old 05-07-2015, 09:48 PM   #8
Registered Member
Regular
 
code_cobra911's Avatar
 
Join Date: May 2014
Posts: 78
An 01 expedition 4x4


Sent from my iPhone using Mustang Evolution
code_cobra911 is offline   Reply With Quote
Old 05-07-2015, 09:49 PM   #9
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
Did you swap cams, intake and heads? And how high are you revving it?
natestang07 is offline   Reply With Quote
Old 05-07-2015, 09:51 PM   #10
Registered Member
Regular
 
code_cobra911's Avatar
 
Join Date: May 2014
Posts: 78
Intake was swapped to a van intake same year just for bigger runners. Cams are the same so are the heads.


Sent from my iPhone using Mustang Evolution
code_cobra911 is offline   Reply With Quote
Old 05-07-2015, 09:51 PM   #11
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
You might be over revving the cams/ intake

---------- Post added at 07:51 PM ---------- Previous post was at 07:51 PM ----------

And it will feel sluggish until those get swapped
natestang07 is offline   Reply With Quote
Old 05-07-2015, 09:53 PM   #12
Registered Member
Regular
 
code_cobra911's Avatar
 
Join Date: May 2014
Posts: 78
The highest I shift at is around 5100 rpm and I have a tune on it too to extend the rev limiter


Sent from my iPhone using Mustang Evolution
code_cobra911 is offline   Reply With Quote
Old 05-07-2015, 09:54 PM   #13
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
You can extend the limiter all you want but at the end of the day those cams and that intake are not built for it. I wouldn't rev that high until they are swapped.
natestang07 is offline   Reply With Quote
Old 05-07-2015, 09:55 PM   #14
Registered Member
Regular
 
code_cobra911's Avatar
 
Join Date: May 2014
Posts: 78
It does it even when cruising so could that still be it? Or could it be something with the drivetrain?


Sent from my iPhone using Mustang Evolution
code_cobra911 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My 92 mustang died please help please wont start HybridTruth93 1979-1995 Mustang GT 2 05-04-2014 04:07 PM
Please help me! Please!! 98StangKid SVT Mustang 0 05-17-2013 10:40 PM
PLEASE, PLEASE HELP!!! Zoe 2005-2010 V6 Mustang 6 03-11-2012 02:19 PM
MT82 Transmission Issue...Please Read and Please HELP DannyDoright 2011-2014 V6 Mustang 5 03-02-2012 09:46 AM
Sold a Car Please, please help!!? booth General Mustang Discussion 9 03-20-2010 10:29 AM

» Like Us On Facebook



06:15 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.