Still running rich at WOT! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-14-2015, 08:25 PM   #1
Registered User
Newbie
 
Join Date: May 2015
Posts: 17
Still running rich at WOT!

So originally on my 01 gt I had just removed the cats, welded on some new pipes. Ever since then I noticed the car runs super rich only when she's hot. I ended up getting a whole new exhaust last week because the old one was so shot. Runs alot better but still the same issue at wot. I bought mil eliminators and they're doing their job. So after all of this being done and resetting the ecu correctly about three times now, I'm starting to come to the conclusion that my car goes from open loop when she first starts cold, to closed loop because everything runs normal when it's warm but not too warm, to open loop again. Would it be the o2 sensors not heating up enough and causing it to go into dummy mode again? I have not replaced the rear exhaust o2 sensors since I bought it last fall. Ive replaced plugs and boots last fall. Cleaned the Maf sensor twice now. I think the only mod I've been able to afford is the exhaust and a bbk intake D: Any help would be awesome. I really just don't have the money to take it anywhere. And I wouldn't want to do that in the first place... also wondered if a cop could go bad when it gets too hot. I've
Metered all of them but they seem to be all good. Thanks guys. P.s. I know it's not oil or antifreeze, and that it's definitely abnormal. I understand that removing cats will make everything more fumy. But not a big cloud when you take off from a light lol.

Sent from my SM-G900P using Mustang Evolution mobile app
hades1346 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-14-2015, 11:06 PM   #2
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,411
The first thing that you should do is scan the car for any trouble codes.
Most auto parts stores can do this for you.
straybullitt is offline   Reply With Quote
Old 07-15-2015, 09:18 AM   #3
Registered User
Newbie
 
Join Date: May 2015
Posts: 17
The only one that comes up is evaporative emissions because of the faulty gasket by my gas tank.

Sent from my SM-G900P using Mustang Evolution mobile app
hades1346 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-15-2015, 03:31 PM   #4
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,411
You should repair that, but I don't think that would cause the symptoms that you described.

How many miles are on the car?
Do you think that the upstream 02 sensors are original?
What color is the smoke, after idling for a few minutes?
straybullitt is offline   Reply With Quote
Old 07-18-2015, 02:32 PM   #5
Registered Member
Regular
 
Speed_Mister's Avatar
 
Join Date: Apr 2012
Location: Central Arkansas
Region: Arkansas
Posts: 1,220
If you have O2 extensions replace them, if not replace O2 sensor, if that doesn't work replace O2 wire harness.


2004 Mustang GT 5 Speed Full Bolt On 370rwhp 440rwtq

---------- Post added at 02:32 PM ---------- Previous post was at 02:32 PM ----------

I had the same problem and it was an extension.


2004 Mustang GT 5 Speed Full Bolt On 370rwhp 440rwtq

---------- Post added at 02:32 PM ---------- Previous post was at 02:32 PM ----------

I had the same problem and it was an extension.


2004 Mustang GT 5 Speed Full Bolt On 370rwhp 440rwtq
__________________
2004 Mustang GT 5 Speed
Full Bolt Ons
370rwhp 470rwtq
12.1 @ 117.9 (1.7) in 1/4th
7.6 @ 92.1 (1.6) in 1/8th
Speed_Mister is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why can't the rich just be happy, with being rich? esra General Car Discussion 20 07-16-2015 04:14 PM
Running to Rich Mustang_Madness 1996-2004 Mustang GT 3 01-29-2012 07:12 AM
3.8 Running Rich mu_stang Pre-2005 V6 Mustang 4 02-10-2011 05:43 AM
87 Mustang has very high idle and running VERY rich. Any ideas? clannan1 1979-1995 Mustang GT 5 08-21-2010 12:25 PM
I'm RICH!!!! I'm RICH!!!! PureVenom 1996-2004 Mustang GT 34 04-23-2009 10:23 AM

» Like Us On Facebook



12:22 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.