Air isn't blowing through vents. Defrost only? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-10-2015, 11:29 PM   #1
Registered Member
Regular
 
thump's Avatar
 
Join Date: Mar 2015
Location: Jackson
Region: Tennessee
Posts: 58
Air isn't blowing through vents. Defrost only?

Been reading different forums and from the title you can see my problem. I have a 03 gt and I assume it's a vacuum leak or ac control module. I'm currently checking for leaks under hood and under dash. I notice this hose separated but dunno if it's correct hose for my problems. I have attached a pic. Should these two red tubes be connected and if not who do they go to. Thanks
Click image for larger version

Name:	ImageUploadedByMustang Evolution1439267331.256672.jpg
Views:	84
Size:	68.3 KB
ID:	189088Click image for larger version

Name:	ImageUploadedByMustang Evolution1439267345.108336.jpg
Views:	83
Size:	67.4 KB
ID:	189089Click image for larger version

Name:	ImageUploadedByMustang Evolution1439267360.399389.jpg
Views:	78
Size:	67.1 KB
ID:	189090Click image for larger version

Name:	ImageUploadedByMustang Evolution1439267371.838578.jpg
Views:	81
Size:	70.2 KB
ID:	189091


"If you build it, they will come"
thump is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-11-2015, 07:50 AM   #2
Registered Member
Regular
 
jeno's Avatar
 
Join Date: May 2015
Location: san antonio texas
Posts: 1,069
You need to have those lines connected here's a pic on my engine how its connected

Sent from my Nexus 6 using Mustang Evolution mobile app
jeno is offline   Reply With Quote
Old 08-11-2015, 07:53 AM   #3
Registered Member
Regular
 
jeno's Avatar
 
Join Date: May 2015
Location: san antonio texas
Posts: 1,069
Click image for larger version

Name:	uploadfromtaptalk1439297571287.jpg
Views:	107
Size:	1.72 MB
ID:	189132

Sent from my Nexus 6 using Tapatalk
jeno is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-11-2015, 08:00 AM   #4
Registered Member
Regular
 
thump's Avatar
 
Join Date: Mar 2015
Location: Jackson
Region: Tennessee
Posts: 58
Thanks man I figured out this morning. Can that hose and plug be bought.


"If you build it, they will come"
thump is offline   Reply With Quote
Old 08-11-2015, 08:02 AM   #5
Registered Member
Regular
 
jeno's Avatar
 
Join Date: May 2015
Location: san antonio texas
Posts: 1,069
Yea just buy new vacuum hose at your local auto parts store

Sent from my Nexus 6 using Tapatalk
jeno is offline   Reply With Quote
Old 08-11-2015, 08:03 AM   #6
Registered Member
Regular
 
thump's Avatar
 
Join Date: Mar 2015
Location: Jackson
Region: Tennessee
Posts: 58
Great I'll swing by there after work.


"If you build it, they will come"
thump is offline   Reply With Quote
Old 08-11-2015, 08:11 AM   #7
Registered Member
Regular
 
jeno's Avatar
 
Join Date: May 2015
Location: san antonio texas
Posts: 1,069
Just have them come out to your car and show them what your looking for so they have a better idea good luck

Sent from my Nexus 6 using Tapatalk
jeno is offline   Reply With Quote
Old 08-11-2015, 08:15 AM   #8
Registered Member
Regular
 
dwbrand's Avatar
 
Join Date: May 2015
Location: Bendena
Region: Kansas
Posts: 457
Talk about breaking at the wrong point...

My 95 F150 did the same thing. Took it to a small Ford dealer who tried telling us the motor had no vacuum and with 25,000 miles needed replaced. I nosed around and found like three broken/decayed vacuum lines. Truck now has 196k on a "junk" motor.


Sent from my iPhone using Mustang Evolution
__________________
2003 Ford Mustang GT
1995 Ford F150 XLT 4x4
1968 Mercury Cougar
dwbrand is offline   Reply With Quote
Old 08-11-2015, 08:24 AM   #9
Registered Member
Regular
 
thump's Avatar
 
Join Date: Mar 2015
Location: Jackson
Region: Tennessee
Posts: 58
Great I'll swing by there after work.


"If you build it, they will come"
thump is offline   Reply With Quote
Old 08-11-2015, 08:27 AM   #10
Registered Member
Regular
 
thump's Avatar
 
Join Date: Mar 2015
Location: Jackson
Region: Tennessee
Posts: 58
Quote:
Originally Posted by dwbrand View Post
Talk about breaking at the wrong point...

My 95 F150 did the same thing. Took it to a small Ford dealer who tried telling us the motor had no vacuum and with 25,000 miles needed replaced. I nosed around and found like three broken/decayed vacuum lines. Truck now has 196k on a "junk" motor.


Sent from my iPhone using Mustang Evolution

Yea they were definitely trying to get over on the inexperienced


"If you build it, they will come"
thump is offline   Reply With Quote
Old 08-12-2015, 06:31 AM   #11
Staff
Regular
Staff
 
scottydsntknow's Avatar
 
Join Date: Apr 2013
Location: JB MDL
Region: New Jersey
Posts: 16,592
Just buy a tube and slip both ends into the tube and there you go. Any vac leak like that can jack up the HVAC controller. Happened to my Expy right after I first got it. Vac line disconnected by the firewall, plugged it back in and have not had a problem since.
__________________
2000 Mustang GT Steeda #0048

Just because I give you advice, doesn't mean I know more than you. Its just means I've done more stupid ****.
scottydsntknow is offline   Reply With Quote
Old 08-12-2015, 05:49 PM   #12
Registered Member
Regular
 
thump's Avatar
 
Join Date: Mar 2015
Location: Jackson
Region: Tennessee
Posts: 58
Where is the Blend door actuator located?


"If you build it, they will come"
thump is offline   Reply With Quote
Old 08-12-2015, 05:55 PM   #13
Registered Member
Regular
 
thump's Avatar
 
Join Date: Mar 2015
Location: Jackson
Region: Tennessee
Posts: 58
Freon installed to the proper amount. Ac now comes on and stay on and is engaged but no cool air blows only hot.


"If you build it, they will come"
thump is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ac blows threw floor and defrost only 95convertible Pre-2005 V6 Mustang 8 09-20-2014 04:16 AM
The fan in my car only is blowing threw defrost? Help 1995boss 1979-1995 Mustang GT 2 08-08-2012 05:54 PM
Blow Through vs. Draw Through, HELP!! CodyNelson 1996-2004 Mustang GT 7 01-06-2012 05:26 PM
Chevy isn't the only transformer USAF_stang Pictures and Videos 10 07-25-2011 06:01 PM
MY AC IN MY 1997 MUSTANG ONLY BLOWS THROUGH THE TOP AND BOTTOM VENTS WHATS WRONG...? hobbard 1996-2004 Mustang GT 1 08-24-2009 01:12 PM

» Like Us On Facebook



12:54 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.