Cruise control question - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-02-2016, 12:08 PM   #1
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 1,382
Cruise control question

I did search, I did! My newly acquired GT convertible has the coveted (ha) Mach 1000 sound system; however, the previous owner installed a POS Boss double din head unit in it. The only speakers working are both the door tweeters and subs and the rear tweeters. I'm going to be buying a factory head unit to go back to stock (I like the stock look) , so that's not the issue at the moment. The real issue is my cruise control does not work. I understand the factory head unit has a speed sensitive volume feature that raises and lowers the volume based on vehicle speed....so, could the fact that whoever installed the aftermarket head unit possible hacked up the wiring or did not use the proper adapters and now that's why my cruise does not work? I've checked all the obvious things, fuse, linkage, clutch pedal switch. They are all there, just wanted to get an opinion on the radio thing before I start throwing parts at it if installing a factory head unit does not make it start working. TIA
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-03-2016, 12:10 AM   #2
Registered Member
Regular
 
Revvv's Avatar
 
Join Date: Apr 2016
Location: Augusta
Region: Georgia
Posts: 3,115
Something is wrong somewhere. My stereo and cruise works great. I have a Kenwood head instead of the original Mach unit.

Like you, I prefer the Mach head unit.

Sent from my VS980 4G using Tapatalk
Revvv is offline   Reply With Quote
Old 06-05-2016, 07:17 AM   #3
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 1,382
Well, I left a dealer review on cars.com for this issue and yesterday the dealer called me (it was not a bad review but I did mention I was disappointed). He offered to pay to have the cruise fixed so if the radio fixes it, he will reimburse me the money. If the radio does not fix it, off to the dealer and he will pay for it. Pretty nice of them, IMO.
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-05-2016, 08:43 AM   #4
Registered Member
Regular
 
Revvv's Avatar
 
Join Date: Apr 2016
Location: Augusta
Region: Georgia
Posts: 3,115
Quote:
Originally Posted by jkeaton View Post
Well, I left a dealer review on cars.com for this issue and yesterday the dealer called me (it was not a bad review but I did mention I was disappointed). He offered to pay to have the cruise fixed so if the radio fixes it, he will reimburse me the money. If the radio does not fix it, off to the dealer and he will pay for it. Pretty nice of them, IMO.
It's always good to hear about a dealership doing the right thing.

Sent from my VS980 4G using Tapatalk
Revvv is offline   Reply With Quote
Old 06-05-2016, 12:19 PM   #5
Registered Member
Regular
 
carlspeed's Avatar
 
Join Date: Jun 2012
Region: Florida
Posts: 24
Sounds like one of the wires might not have been hooked up correctly, and it's causing your issues. The answer is way easier than diagnosing it though. Good luck!
__________________
Carl
Lots of F-Bodys and now...
'12 Sterling Gray 5.0 M6 w/ Brembos, 3.73s, Borla S-Type catback, and 15% tint
carlspeed is offline   Reply With Quote
Old 06-09-2016, 06:43 AM   #6
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 1,382
Well if anyone ever has this problem, I fixed it. Picked up a used MACH 1000 head unit from ebay. The wiring was a bit hacked up by whoever installed the aftermarket head unit, but after I got everything back together (i.e. original) the cruise control now works. Also the subs and the rest of the speakers. This thing sounds good!


__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Old 06-10-2016, 09:01 AM   #7
Registered Member
Regular
 
Join Date: Feb 2016
Location: Cheyenne
Region: Wyoming
Posts: 74
The only part of the 460 my car still has is the badges.

Cruise works fine.
Indy is offline   Reply With Quote
Old 06-11-2016, 01:09 PM   #8
Registered Member
Regular
 
salsa04GT's Avatar
 
Join Date: Apr 2016
Location: Pittsburgh
Region: Pennsylvania
Posts: 90
Now that your cruise works tell me do you have an indicator light on the cluster telling you it's on or set? It's not hard to just press the buttons and let off the throttle to tell, but just nit picking about the cluster light I guess
salsa04GT is offline   Reply With Quote
Old 06-11-2016, 05:11 PM   #9
Registered Member
Regular
 
Revvv's Avatar
 
Join Date: Apr 2016
Location: Augusta
Region: Georgia
Posts: 3,115
Quote:
Originally Posted by salsa04GT View Post
Now that your cruise works tell me do you have an indicator light on the cluster telling you it's on or set? It's not hard to just press the buttons and let off the throttle to tell, but just nit picking about the cluster light I guess
I have an aftermarket stereo and my indicator light does not work. Cruise control works just fine though.

Sent from my VS980 4G using Tapatalk
Revvv is offline   Reply With Quote
Old 06-11-2016, 05:14 PM   #10
Registered Member
Regular
 
Revvv's Avatar
 
Join Date: Apr 2016
Location: Augusta
Region: Georgia
Posts: 3,115
Quote:
Originally Posted by jkeaton View Post
Well if anyone ever has this problem, I fixed it. Picked up a used MACH 1000 head unit from ebay. The wiring was a bit hacked up by whoever installed the aftermarket head unit, but after I got everything back together (i.e. original) the cruise control now works. Also the subs and the rest of the speakers. This thing sounds good!


If I run across an original Mach head unit it will be put back in my car. My Kenwood has a lot of features, but I prefer the factory set up.

Sent from my VS980 4G using Tapatalk
Revvv is offline   Reply With Quote
Old 06-11-2016, 05:20 PM   #11
Registered Member
Regular
 
Slater2111's Avatar
 
Join Date: Dec 2014
Location: Jacksonville
Region: Florida
Posts: 1,001
I have an original Mach 1000 head unit. There's the common CD stuck in it that won't eject. If I can find it I'll PM you if you really want it.


2003 GT: JLT CAI, summit 75mm TB, C&L plenum, 24# injectors, Mac Prochamber, SLP LM1 cat back, 3.73 Gears, FR500 Diff, FR500 diff cover, Jmod trans and shift kit, Max Motorsports subframes, Koni oranges front and rear, DBA discs front and rear, shrader performance rear seat delete, APSX D2 wideband, MPT happy customer.
Slater2111 is offline   Reply With Quote
Old 06-12-2016, 12:41 PM   #12
Registered Member
Regular
 
Revvv's Avatar
 
Join Date: Apr 2016
Location: Augusta
Region: Georgia
Posts: 3,115
Quote:
Originally Posted by Slater2111 View Post
I have an original Mach 1000 head unit. There's the common CD stuck in it that won't eject. If I can find it I'll PM you if you really want it.


2003 GT: JLT CAI, summit 75mm TB, C&L plenum, 24# injectors, Mac Prochamber, SLP LM1 cat back, 3.73 Gears, FR500 Diff, FR500 diff cover, Jmod trans and shift kit, Max Motorsports subframes, Koni oranges front and rear, DBA discs front and rear, shrader performance rear seat delete, APSX D2 wideband, MPT happy customer.
Definitely send me a PM. I'm sure I can repair the CD player.

Sent from my VS980 4G using Tapatalk
Revvv is offline   Reply With Quote
Old 06-12-2016, 08:06 PM   #13
Registered Member
Regular
 
salsa04GT's Avatar
 
Join Date: Apr 2016
Location: Pittsburgh
Region: Pennsylvania
Posts: 90
Cruise control question

Quote:
Originally Posted by Revvv View Post
I have an aftermarket stereo and my indicator light does not work. Cruise control works just fine though.

Sent from my VS980 4G using Tapatalk

I have the original Mach system in my 04 GT. never replaced to my knowledge. The only other previous owner was over 70 yrs old. But cluster light still doesn't work. Cruise works great. Is there even a light for the cruise?
salsa04GT is offline   Reply With Quote
Old 06-12-2016, 09:35 PM   #14
Registered Member
Regular
 
Revvv's Avatar
 
Join Date: Apr 2016
Location: Augusta
Region: Georgia
Posts: 3,115
Quote:
Originally Posted by salsa04GT View Post
I have the original Mach system in my 04 GT. never replaced to my knowledge. The only other previous owner was over 70 yrs old. But cluster light still doesn't work. Cruise works great. Is there even a light for the cruise?
I honestly don't know, but my cruise control works regardless. I'm too lazy too look up whether or not a cruise indicator exists on our New Edge Mustangs. Lol

Sent from my VS980 4G using Tapatalk
Revvv is offline   Reply With Quote
Old 06-12-2016, 11:01 PM   #15
Registered Member
Regular
 
Revvv's Avatar
 
Join Date: Apr 2016
Location: Augusta
Region: Georgia
Posts: 3,115
All of the research I have found so far claims that there IS NOT a cruise control indicator light in the New Edge Mustangs.

Sent from my VS980 4G using Tapatalk
Revvv is offline   Reply With Quote
Old 06-12-2016, 11:38 PM   #16
Registered Member
Regular
 
99GT4.6's Avatar
 
Join Date: Mar 2016
Location: Ottawa
Region: Canada
Posts: 26
My 1999 GT has no indicator light for the cruise control. FWIW it also has the stock Mach 460 audio in it.
99GT4.6 is offline   Reply With Quote
Old 06-13-2016, 06:58 AM   #17
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 1,382
Quote:
Originally Posted by salsa04GT View Post
Now that your cruise works tell me do you have an indicator light on the cluster telling you it's on or set? It's not hard to just press the buttons and let off the throttle to tell, but just nit picking about the cluster light I guess
No, there are no indicators telling you the cruise is on.
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Old 06-13-2016, 07:00 AM   #18
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 1,382
Quote:
Originally Posted by Revvv View Post
Definitely send me a PM. I'm sure I can repair the CD player.

Sent from my VS980 4G using Tapatalk
Copy me on that PM too! I have "CD ERROR". I've done some reading on here regarding that, but most threads just say it's common and none that I could find mentioned a fix.
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Old 01-09-2017, 02:33 PM   #19
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 1,382
Question for anyone who has upgraded the Mach 1000 head unit with aftermarket head unit, how are the rear subs controlled? With the stock Mach 1000 head unit, there is a button to turn the "Mach 1000" on and off. What would control it on an aftermarket unit?
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Old 01-09-2017, 04:23 PM   #20
Road Trip!
Regular
 
Join Date: Jun 2014
Location: Saskatoon, Saskatchewan
Region: Canada
Posts: 1,502
Send a message via Skype™ to Gravydog316
The cruise control on the New Edge was available as an "accessory," so there wasn't any indicator on the dash.


Autocorrect is my worst enema...
Gravydog316 is offline   Reply With Quote
Old 01-09-2017, 05:04 PM   #21
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 1,382
Quote:
Originally Posted by Gravydog316 View Post
The cruise control on the New Edge was available as an "accessory," so there wasn't any indicator on the dash.


Autocorrect is my worst enema...
Yes. We figured that out awhile back. Thanks.
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Old 01-09-2017, 05:26 PM   #22
Road Trip!
Regular
 
Join Date: Jun 2014
Location: Saskatoon, Saskatchewan
Region: Canada
Posts: 1,502
Send a message via Skype™ to Gravydog316
Quote:
Originally Posted by jkeaton View Post
Yes. We figured that out awhile back. Thanks.

Why is everyone replying to 5-year old threads lately(????)


Autocorrect is my worst enema...
Gravydog316 is offline   Reply With Quote
Old 01-09-2017, 07:01 PM   #23
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 1,382
Actually 6 months.
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Old 01-09-2017, 07:20 PM   #24
Road Trip!
Regular
 
Join Date: Jun 2014
Location: Saskatoon, Saskatchewan
Region: Canada
Posts: 1,502
Send a message via Skype™ to Gravydog316
Cruise control question

Quote:
Originally Posted by jkeaton View Post
Yes. We figured that out awhile back. Thanks.

(I was answering for NEW viewers) (...yeah... that's believable)
Click image for larger version

Name:	ImageUploadedByMustang Evolution1484011060.412935.jpg
Views:	27
Size:	215.8 KB
ID:	215289
...& those people from the 60s lol
Gravydog316 is offline   Reply With Quote
Old 01-09-2017, 09:53 PM   #25
Registered Member
Regular
 
Join Date: Nov 2016
Location: riverside
Region: California
Posts: 167
Just run the cluster diagnostic and you can see all of the idiot lights available.
Neuron is offline   Reply With Quote
Old 01-10-2017, 06:48 AM   #26
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 1,382
Grr...forget about the dang cruise control light. I'm asking about the Mach 1000 system....
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Old 01-10-2017, 01:21 PM   #27
Road Trip!
Regular
 
Join Date: Jun 2014
Location: Saskatoon, Saskatchewan
Region: Canada
Posts: 1,502
Send a message via Skype™ to Gravydog316
Quote:
Originally Posted by Neuron View Post
Just run the cluster diagnostic and you can see all of the idiot lights available.

Don't need to.

---------- Post added at 12:21 PM ---------- Previous post was at 12:20 PM ----------

Quote:
Originally Posted by jkeaton View Post
Grr...forget about the dang cruise control light. I'm asking about the Mach 1000 system....

What cruise control light?
There ISN'T a cruise control light.
Gravydog316 is offline   Reply With Quote
Old 01-10-2017, 02:34 PM   #28
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 1,382
Quote:
Originally Posted by Gravydog316 View Post
Don't need to.

---------- Post added at 12:21 PM ---------- Previous post was at 12:20 PM ----------

What cruise control light?
There ISN'T a cruise control light.
Wait! You said there wasn't one! I'm so confused.
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Old 01-11-2017, 09:40 AM   #29
Road Trip!
Regular
 
Join Date: Jun 2014
Location: Saskatoon, Saskatchewan
Region: Canada
Posts: 1,502
Send a message via Skype™ to Gravydog316
Quote:
Originally Posted by jkeaton View Post
Wait! You said there wasn't one! I'm so confused.

You said "forget about the cruise control light," but there isn't one to forget about!
Gravydog316 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Factory speed control or dealer speed control (cruise control) Otlaw80 1979-1995 Mustang GT 6 08-18-2011 08:42 PM
tv cable or cruise control ??? fastang11 Pre-2005 V6 Mustang 4 12-25-2005 02:30 PM
1995 3.8 cruise control? v6Stangin95 Pre-2005 V6 Mustang 7 09-24-2005 04:02 AM
WTB: Trunk Carpet (Black) and Cruise Control On/Off Black95GT Mustang Parts for Sale and Wanted 0 02-16-2004 08:23 PM

» Like Us On Facebook



07:13 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.