Fuse for brake lights keeps blowing. - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-21-2016, 08:02 PM   #1
Registered Member
Regular
 
99GT4.6's Avatar
 
Join Date: Mar 2016
Location: Ottawa
Region: Canada
Posts: 26
Fuse for brake lights keeps blowing.

The 15A fuse 33 under my dash keeps blowing resulting in my car having no brake lights (or cruise control). If I put a new fuse in and hold down the brake pedal the lights come on for about 15 seconds then the fuse blows again. I tried unplugging the switch on the brake pedal and jumping the terminals with pliers and the fuse blew again so I'm assuming my problem is not with the switch grounding out or failing. I'm planning on getting a multimeter and testing the wiring next. Has anyone else had this problem?
99GT4.6 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-21-2016, 08:58 PM   #2
Registered Member
Regular
 
parkerbickel's Avatar
 
Join Date: Apr 2016
Location: La Junta
Region: Colorado
Posts: 269
Check to make sure you don't have a short anywhere.

Sent from my SM-G935V using Mustang Evolution mobile app
__________________
2011 V6 Race Red - Roush Axle Back Exhaust, GT500 Steering Wheel, GROM Audio Bluetooth Module, Raxiom Aero Smoked Tail lights, Raxiom GPS
parkerbickel is offline   Reply With Quote
Old 08-22-2016, 06:09 AM   #3
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
A fuse blows because it's circuit is drawing more then the wiring/fuse can handle. Never install a larger fuse, as the wiring will get hot, and lead to a fire.

Did you recently replace the taillight housings, or the third brake light housing? Did you do any work on the car in or around the brake light housings?
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-22-2016, 06:23 AM   #4
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 4,779
I would start by unplugging the connector to both rear lights and see if it blows...if not one at a time re-connect them this will isolate it to one light. if it still blows remember the 3rd brake light and disconnect that. If it continiues to pop then you have a wiring issue.
__________________
New England Mustang Cruise July 29th
http://www.mustangevolution.com/forum/f296/t394033/
regional forums or PM Me or Robostang
Strange Mud is offline   Reply With Quote
Old 08-22-2016, 10:14 AM   #5
twk
Evolution's Finest
Supporter
 
twk's Avatar
 
Join Date: Aug 2013
Location: Harrisburg
Region: North Carolina
Posts: 128
That is excellent advice right there.
twk is offline   Reply With Quote
Old 08-22-2016, 12:07 PM   #6
Registered Member
Regular
 
99GT4.6's Avatar
 
Join Date: Mar 2016
Location: Ottawa
Region: Canada
Posts: 26
Haven't touched the brake light housings or the third brake light this year at all.
99GT4.6 is offline   Reply With Quote
Old 08-22-2016, 12:34 PM   #7
Road Trip!
Regular
 
Join Date: Jun 2014
Location: Saskatoon, Saskatchewan
Region: Canada
Posts: 1,502
Send a message via Skype™ to Gravydog316
Maybe the wiring got wet & damaged (?)


RIP Dick Assman•1934~2016
Gravydog316 is offline   Reply With Quote
Old 08-22-2016, 11:01 PM   #8
Registered Member
Regular
 
KATO's Avatar
 
Join Date: Jul 2011
Location: Cutler Bay
Region: Florida
Posts: 1,558
Send a message via Yahoo to KATO
Fuse Blowing.

The Hardest part is going to be finding the exposed wire that's Grounding out. Could be anywhere, could even be in the Rear near the lights. Good luck finding it.
__________________
07 GT. SCT: CUSTOM TUNE by "MUSTANG SPECIALTIES". LMR: GEN2 2010 STYLE HEADLIGHTS, RAXIOM: 2010 SMOKED COYOTE TAIL LIGHTS, WHEELS: STAGGERED WHL 22X8.5F-22X10R.
KATO is offline   Reply With Quote
Old 08-24-2016, 11:23 AM   #9
Registered Member
Regular
 
99GT4.6's Avatar
 
Join Date: Mar 2016
Location: Ottawa
Region: Canada
Posts: 26
So I went outside to try to fix this problem and now it is working properly. All lights come on and the fuse isn't blowing. I think this car is possessed. Thanks for the advice everyone!
99GT4.6 is offline   Reply With Quote
Old 08-24-2016, 02:29 PM   #10
Registered Member
Regular
 
KATO's Avatar
 
Join Date: Jul 2011
Location: Cutler Bay
Region: Florida
Posts: 1,558
Send a message via Yahoo to KATO
That's good, but there still maybe a wire that's occasionally touching Metal and Grounding.
__________________
07 GT. SCT: CUSTOM TUNE by "MUSTANG SPECIALTIES". LMR: GEN2 2010 STYLE HEADLIGHTS, RAXIOM: 2010 SMOKED COYOTE TAIL LIGHTS, WHEELS: STAGGERED WHL 22X8.5F-22X10R.
KATO is offline   Reply With Quote
Old 08-24-2016, 02:31 PM   #11
Registered Member
Regular
 
99GT4.6's Avatar
 
Join Date: Mar 2016
Location: Ottawa
Region: Canada
Posts: 26
I'm sure there probably is. The part that confuses me is it would always take about 15 seconds of pushing the pedal to blow the fuse. It never would blow instantly which I would expect if it had a dead short to ground.
99GT4.6 is offline   Reply With Quote
Old 12-23-2016, 10:50 PM   #12
Registered Member
Regular
 
KATO's Avatar
 
Join Date: Jul 2011
Location: Cutler Bay
Region: Florida
Posts: 1,558
Send a message via Yahoo to KATO
Hey, did you ever find out what that Grounding problem was? Was it a wire or did it completely stop blowing after you tinkered with it?
__________________
07 GT. SCT: CUSTOM TUNE by "MUSTANG SPECIALTIES". LMR: GEN2 2010 STYLE HEADLIGHTS, RAXIOM: 2010 SMOKED COYOTE TAIL LIGHTS, WHEELS: STAGGERED WHL 22X8.5F-22X10R.
KATO is offline   Reply With Quote
Old 12-23-2016, 11:42 PM   #13
Registered Member
Regular
 
99GT4.6's Avatar
 
Join Date: Mar 2016
Location: Ottawa
Region: Canada
Posts: 26
Completely stopped blowing after I messed with it. The car is in storage for winter now so I'll have to see if it is still good in spring.
99GT4.6 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FML. Number 18 fuse for ccrm and ignition system keeps blowing 95gtnewb 1979-1995 Mustang GT 0 03-17-2015 04:16 AM
#18 fuse keeps blowing NFLjunkeez 1979-1995 Mustang GT 5 02-22-2013 10:08 PM
Same fuse keeps blowing. Help! blue-saleen Mustang Audio & Video 0 05-11-2011 05:47 PM
#8 Fuse keeps blowing in Ford Mustang... Possible cause? gilmar General Mustang Discussion 2 03-18-2010 10:41 PM
This stupid car again! 1997 mustang fuel pump fuse keeps blowing? camden Pre-2005 V6 Mustang 5 08-23-2009 02:47 AM

» Like Us On Facebook



04:48 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.