V6 to v8 swap - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Join Mustang Evolution Today


Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-15-2016, 09:30 PM   #1
Registered Member
Regular
 
Blue Angel's Avatar
 
Join Date: Aug 2014
Location: San Antonio
Region: Texas
Posts: 104
V6 to v8 swap

I swaped out my old v6 n put a v8. I changed everything over from a donor car being instrument panel ignition cylinder computer and the key from the door in car everything is hooked up properly but the car will not start it just cranks but no fire the fuel is all hooked up properly but there is still no fire anybody know what it could be?

Sent from my SM-N910P using Mustang Evolution mobile app
Blue Angel is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-15-2016, 11:00 PM   #2
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,024
When you turn the key to the on position do all of the warning lights in the instrument cluster light up as normal?
Is the theft light flashing when the ignition is in the on position?
straybullitt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-16-2016, 04:04 AM   #3
Registered Member
Regular
 
Blue Angel's Avatar
 
Join Date: Aug 2014
Location: San Antonio
Region: Texas
Posts: 104
Quote:
Originally Posted by straybullitt View Post
When you turn the key to the on position do all of the warning lights in the instrument cluster light up as normal?
Is the theft light flashing when the ignition is in the on position?
Yes all the lights come on and it clicks when itry n start it but no crank, no the theft light is not flashing

Sent from my SM-N910P using Mustang Evolution mobile app
Blue Angel is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-16-2016, 05:44 AM   #4
Evolution's Finest
Supporter
 
ronnie948's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach
Region: Florida
Posts: 3,815
If it clicks, Check out the battery. It may not have enough juice to crank it over.
Ronnie
__________________
2012-candy red- V-6 MCA, Automatic Trans. CFM Valve cover breather. MMD blackTail light trim.Magnaflow axle back street mufflers, JLT oil catch can.MMD hood struts.
Airaid Cold Air intake. red caliper covers, 3.7L performance engine cover, Flat black hood spears.Boss 302 strut brace, CDC rear panel, Trunk Cargo net,--Dash carpet cover,
Viser stickers to cover ugly yellow warning crap,Aluminum driveshafft and Swarr Bar.
ronnie948 is offline   Reply With Quote
Old 09-16-2016, 06:03 AM   #5
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 685
Quote:
Originally Posted by Blue Angel View Post
Yes all the lights come on and it clicks when itry n start it but no crank, no the theft light is not flashing

Sent from my SM-N910P using Mustang Evolution mobile app
Click but not turning over is indicative of a weak battery or bad connections. There is a difference between not turning over and not starting.
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Old 09-16-2016, 06:03 AM   #6
Registered Member
Regular
 
wmschoonover's Avatar
 
Join Date: Mar 2016
Location: Owensboro
Region: Kentucky
Posts: 543
I'd also check all the connections at the frame, both battery posts and the starter. Check for corrosion and or loose connections.


Sent from my iPhone using Mustang Evolution
wmschoonover is offline   Reply With Quote
Old 09-16-2016, 09:38 AM   #7
Registered Member
Regular
 
Blue Angel's Avatar
 
Join Date: Aug 2014
Location: San Antonio
Region: Texas
Posts: 104
Quote:
Originally Posted by ronnie948 View Post
If it clicks, Check out the battery. It may not have enough juice to crank it over.
Ronnie
We had it hooked up to a jump starter n still nothing even tryed with a brand new battery

Sent from my SM-N910P using Mustang Evolution mobile app
Blue Angel is offline   Reply With Quote
Old 09-16-2016, 09:40 AM   #8
Registered Member
Regular
 
Blue Angel's Avatar
 
Join Date: Aug 2014
Location: San Antonio
Region: Texas
Posts: 104
Quote:
Originally Posted by wmschoonover View Post
I'd also check all the connections at the frame, both battery posts and the starter. Check for corrosion and or loose connections.


Sent from my iPhone using Mustang Evolution
This is the only thing that dosent match up with the body harness on my car (the v6) the engine harness is the v8 ofcourse. Do i need to switch it out?

Sent from my SM-N910P using Mustang Evolution mobile app
Attached Thumbnails
Click image for larger version

Name:	1474040364254.jpg
Views:	51
Size:	47.4 KB
ID:	205114  
Blue Angel is offline   Reply With Quote
Old 09-16-2016, 10:26 AM   #9
Lorraine's driver

Regular
Supporter
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,565
Quote:
Originally Posted by Blue Angel View Post
This is the only thing that dosent match up with the body harness on my car (the v6) the engine harness is the v8 ofcourse. Do i need to switch it out?
Yup!
__________________
ab_mach1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
To Swap, or not to swap...... Strongarm 1979-1995 Mustang GT 5 02-05-2008 01:39 PM

» Like Us On Facebook



10:55 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.