Ran the twinturbo for the first time - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-11-2010, 10:10 PM   #1
Registered User
Newbie
 
turbofox's Avatar
 
Join Date: Jun 2010
Region: Oklahoma
Posts: 15
Send a message via AIM to turbofox Send a message via Yahoo to turbofox
Exclamation Ran the twinturbo for the first time

DIDNT LAUNCH IT OR ANYTHING. DOGGED IT OFF THE LINE CAUSE I DIDNT WANT IT TI SPIN.





turbofox is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-11-2010, 10:42 PM   #2
Registered Member
Regular
 
1234's Avatar
 
Join Date: Feb 2007
Region: Missouri
Posts: 1,292
Re: Ran the twinturbo for the first time

Badass. Now it needs slicks to see what it can really do.
__________________
03 GT Charcoal Silver Metallic - Stolen
1234 is offline   Reply With Quote
Old 07-11-2010, 11:23 PM   #3
Registered User
Newbie
 
turbofox's Avatar
 
Join Date: Jun 2010
Region: Oklahoma
Posts: 15
Send a message via AIM to turbofox Send a message via Yahoo to turbofox
Re: Ran the twinturbo for the first time

ya i bet it could do alot better if i launched it harder. not sure tho. wee will see nextweek
turbofox is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-12-2010, 10:47 AM   #4
Registered Member
Regular
 
1234's Avatar
 
Join Date: Feb 2007
Region: Missouri
Posts: 1,292
Re: Ran the twinturbo for the first time

Be sure to post a video. By the way your car is sexy as hell.
__________________
03 GT Charcoal Silver Metallic - Stolen
1234 is offline   Reply With Quote
Old 07-12-2010, 02:39 PM   #5
Registered User
Newbie
 
turbofox's Avatar
 
Join Date: Jun 2010
Region: Oklahoma
Posts: 15
Send a message via AIM to turbofox Send a message via Yahoo to turbofox
Re: Ran the twinturbo for the first time

ha thanks alot bro and will do on the vid
turbofox is offline   Reply With Quote
Old 07-12-2010, 06:26 PM   #6
Registered Member
Regular
 
iwannagofast's Avatar
 
Join Date: Aug 2006
Region: Wisconsin
Posts: 413
Re: Ran the twinturbo for the first time

why didnt i see any numbers?
iwannagofast is offline   Reply With Quote
Old 07-12-2010, 07:23 PM   #7
Registered Member
Regular
 
hottcobra's Avatar
 
Join Date: May 2007
Region: Louisiana
Posts: 2,638
Re: Ran the twinturbo for the first time

Quote:
Originally Posted by iwannagofast View Post
why didnt i see any numbers?
I second that.
__________________

2006 Mustang GT lots of mods ex wife has it
1979 corvette stingray #'s matching 47K org. miles
1970Chevelle SS 454 big block Old School 500hp Sold
hottcobra is offline   Reply With Quote
Old 07-12-2010, 11:04 PM   #8
Registered User
Newbie
 
turbofox's Avatar
 
Join Date: Jun 2010
Region: Oklahoma
Posts: 15
Send a message via AIM to turbofox Send a message via Yahoo to turbofox
Re: Ran the twinturbo for the first time

they dont post numbers till midnight...sux
turbofox is offline   Reply With Quote
Old 07-22-2010, 01:24 PM   #9
Registered Member
Regular
 
67mustang97's Avatar
 
Join Date: Jul 2008
Region: Vermont
Posts: 645
Re: Ran the twinturbo for the first time

Two Turbo's. lol Bad *** Stang!
__________________


02 GT 5 spd. Best 1/4 12.28 @ 112mph
67mustang97 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help need to know what stall converter to get for the twinturbo?!?!?!?!?!?! turbofox 1979-1995 Mustang GT 3 08-09-2010 09:23 AM
Ran into a very nice S197 HotRodRunning General Mustang Discussion 0 03-28-2009 04:29 PM
Ran a 13.8 in the 1/4 PureVenom Pictures and Videos 12 11-30-2006 09:49 PM
Ran my Mom's 03 V6 Accord v6stanger Pre-2005 V6 Mustang 6 11-11-2003 10:33 AM
funny picture I saw a long time ago and ran into again fast64 The Bar 41 07-27-2003 07:01 PM

» Like Us On Facebook



04:19 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.