My heater is not blowing hot air?!? - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-03-2010, 01:30 AM   #1
bao
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 41
My heater is not blowing hot air?!?

Ok i know there was someone earlier that asked this same question but my circumstance is a little different. My engine is brand new, including the thermostat, water pump and the radiator (along with other things). We recently added a coolant booster so that the engine runs a little cooler (for performance purposes), now my heater hardly blows any hot air unless im driving in a really high rpm (the car is standard, '99 mustang V6) is it the additive? or something else?
bao is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-03-2010, 02:02 AM   #2
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 31
My heater is not blowing hot air?!?

you might try feeling the heater hose to see if they are hot. i,am thinking maybe it,s the heater core starting to plug up.
stanley is offline   Reply With Quote
Old 03-03-2010, 02:30 AM   #3
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 42
My heater is not blowing hot air?!?

The tip is this is a new engine, or at least new cooling parts. Your cooling system needs to be bled, you have an air pocket. take the radiator cap off. let it idle for about 15 minutes and then check the coolant level. Turn off the engine and add coolant, including filling the overflow reservoir.
hobbard is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-03-2010, 03:28 AM   #4
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 39
My heater is not blowing hot air?!?

why add a coolant booster?

all you had to do was get a lower temperature thermostat..
arrin is offline   Reply With Quote
Old 03-03-2010, 03:43 AM   #5
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 39
My heater is not blowing hot air?!?

the first thing i would try is a new thermostat even if it is new some times new ones are bad
talmadge80 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:20 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.