Car runs rough - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-15-2013, 06:30 PM   #1
Registered Member
Regular
 
Liebert91stang's Avatar
 
Join Date: Jun 2013
Location: New Albany
Region: Indiana
Posts: 375
Car runs rough

Have a friend with a 93 gt and it runs to the point of almost die at 1000 rpm.what could it be?changed the headers and h pipe but still no luck.maybe oxygen sensors?
Liebert91stang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-15-2013, 06:32 PM   #2
slow281
Regular
Supporter
 
sixpac's Avatar
 
Join Date: Mar 2012
Location: Cedar Rapids
Region: Nebraska
Posts: 3,162
Quote:
Originally Posted by Liebert91stang View Post
Have a friend with a 93 gt and it runs to the point of almost die at 1000 rpm.what could it be?changed the headers and h pipe but still no luck.maybe oxygen sensors?
Changing headers and H pipe wouldn't make a car run bad? Try a tune up. Plugs wires coil cap and rotor
__________________
Need more Horsepower? Add a sticker. Contact me for vinyl stickers pre-made and custom!
Stick on Horsepower <- Click Here and like my Page!
2001 GT - True Blue
2003 V6 - Zinc Yellow
1990 LX 2.3 - project
sixpac is offline   Reply With Quote
Old 08-15-2013, 06:38 PM   #3
Registered Member
Regular
 
MidnightBlueGT's Avatar
 
Join Date: Apr 2013
Location: Charlotte
Region: North Carolina
Posts: 3,887
+1
MidnightBlueGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-15-2013, 06:52 PM   #4
Registered Member
Regular
 
Liebert91stang's Avatar
 
Join Date: Jun 2013
Location: New Albany
Region: Indiana
Posts: 375
Has new plugs and cap

---------- Post added at 05:52 PM ---------- Previous post was at 05:48 PM ----------

Exhaust had leak and thought it giving false readings to oxygen sensors
Liebert91stang is offline   Reply With Quote
Old 08-15-2013, 10:49 PM   #5
slow281
Regular
Supporter
 
sixpac's Avatar
 
Join Date: Mar 2012
Location: Cedar Rapids
Region: Nebraska
Posts: 3,162
Quote:
Originally Posted by Liebert91stang View Post
Has new plugs and cap

---------- Post added at 05:52 PM ---------- Previous post was at 05:48 PM ----------

Exhaust had leak and thought it giving false readings to oxygen sensors
Most of the time o2 sensors won't make a car run bad..
__________________
Need more Horsepower? Add a sticker. Contact me for vinyl stickers pre-made and custom!
Stick on Horsepower <- Click Here and like my Page!
2001 GT - True Blue
2003 V6 - Zinc Yellow
1990 LX 2.3 - project
sixpac is offline   Reply With Quote
Old 08-16-2013, 04:00 PM   #6
Registered Member
Regular
 
Liebert91stang's Avatar
 
Join Date: Jun 2013
Location: New Albany
Region: Indiana
Posts: 375
Ok thanks for the info.it was his moms car and I'msure she put cheap gas and baby it.he probably need to take it out and teem it a little to clean it out haha that's what I would do.maybe write my name with some tread ; )
Liebert91stang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:29 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.