Speedometer MyColor lights will not turn on. - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-14-2013, 06:44 PM   #1
Registered Member
Regular
 
Tyrannax's Avatar
 
Join Date: Oct 2012
Region: Texas
Posts: 93
Speedometer MyColor lights will not turn on.

So I got into my car the other day, flipped on the headlights (which work) and noticed my speedometer lights would not turn on. What issue am I looking at here? My car is an 05 v6.

Thanks guys.
__________________
Affectionately "The Red Raptor"

Ford Racing CIA, X-Pipe, GT500 Takeoffs, Bama Tuned, X-Charger and Intercooler.
Tyrannax is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-14-2013, 07:48 PM   #2
Registered Member
Regular
 
Autobadges.com's Avatar
 
Join Date: May 2003
Location: Southern Cali
Region: California
Posts: 678
fuse probably
__________________
******Click Banner for more information!******
http://www.mustangevolution.com/forum/signatureuploads/sigpic4116_1.gif
Check out AutoBadges.com's Demo Vehicle!
Autobadges.com is offline   Reply With Quote
Old 09-14-2013, 11:25 PM   #3
Registered Member
Regular
 
Fader's Avatar
 
Join Date: Jul 2013
Location: Boise
Region: Idaho
Posts: 249
Quote:
Originally Posted by Tyrannax View Post
So I got into my car the other day, flipped on the headlights (which work) and noticed my speedometer lights would not turn on. What issue am I looking at here? My car is an 05 v6.

Thanks guys.
Is the white lighting working, with the headlights off?
Fader is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-15-2013, 01:32 AM   #4
Registered Member
Regular
 
xxPIKExx's Avatar
 
Join Date: Jun 2013
Location: Ft Lauderdale
Region: Florida
Posts: 450
Is the interior dimmer turned to off? Seems obvious but I accidentally turned it off once and it took me a few to figure it out. Still don't know how they got turned off as I never touch that knob
xxPIKExx is offline   Reply With Quote
Old 09-15-2013, 02:05 AM   #5
Registered Member
Regular
 
LAS97GT's Avatar
 
Join Date: Jan 2012
Location: Spring Lake
Region: North Carolina
Posts: 681
Try pulling your cluster and reseating your connectors. It rare that all the bulbs blow so check your fuses. dash lights is one of the rarest things that fault out totally. Might be a corroded connector. Try pulling the cluster and use dielectric grease before re-connecting after cleaning the connectors.
__________________
---Las97GT
LAS97GT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:34 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.