97 gt suspension - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-28-2013, 07:58 PM   #1
Registered Member
Regular
 
Davesorl04gt's Avatar
 
Join Date: Nov 2013
Location: Euharlee
Region: Georgia
Posts: 165
97 gt suspension

Got a 97 GT 5 speed Christmas morning, car runs good but when you push down the accelerator it feels like the front end dips a little to the right. Or the rear digs a little to the left, hard to tell the difference. Don't think it is the alignment because when I let go of the wheel it goes straight. Any Ideas?
Davesorl04gt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-28-2013, 08:38 PM   #2
Registered Member
Regular
 
H.Doofenshmirtz's Avatar
 
Join Date: Jun 2013
Location: Queensland
Region: Australia
Posts: 267
Im far from an expert here, but that sounds like a bad motor mount
__________________
No work and no pony makes Doof a dull boy...
H.Doofenshmirtz is offline   Reply With Quote
Old 12-28-2013, 10:39 PM   #3
Registered Member
Regular
 
Slow4V's Avatar
 
Join Date: Feb 2013
Location: Sa
Region: Alabama
Posts: 2,208
It's called torque (;
Slow4V is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-28-2013, 11:32 PM   #4
Registered Member
Regular
 
Black on Boss's Avatar
 
Join Date: Nov 2012
Location: Perry, GA
Region: Georgia
Posts: 7,204
Quote:
Originally Posted by Slow4V View Post
It's called torque (;
^ this guy! Lol
Black on Boss is offline   Reply With Quote
Old 12-29-2013, 09:41 AM   #5
Registered Member
Regular
 
tonyd01gt's Avatar
 
Join Date: Feb 2013
Location: ayden
Region: North Carolina
Posts: 1,065
Quote:
Originally Posted by Slow4V View Post
It's called torque (;
+1. ford are known to torque to the right.
tonyd01gt is offline   Reply With Quote
Old 12-29-2013, 10:12 AM   #6
Registered Member
Regular
 
Davesorl04gt's Avatar
 
Join Date: Nov 2013
Location: Euharlee
Region: Georgia
Posts: 165
I like torque, not to fond of broken motor mounts, but if that what it is, that's what it is. Not too bad. If it is torque, cant wait to get the IP heads and intake on it. Then I'll probably have to change the motor mounts anyway.
Davesorl04gt is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:57 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.