Check engine light :( - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-04-2014, 12:01 AM   #1
Registered Member
Regular
 
G3racing's Avatar
 
Join Date: Feb 2014
Location: Houston
Region: Texas
Posts: 163
Check engine light :(

OK so I bought a steeda cai installed it tuned my car ran great later on their check engine light came on and the code said bank 1 was running lean. Need help my car is running like **** and getting 7mpg I heard something about battery disconnect to fix it but idk

Sent from my SAMSUNG-SGH-I337 using Mustang Evolution mobile app
__________________
2014 Mustang V6 Manual
AMR Charcoal Wheel & NITTO Tire Kit - 20x8.5
G3racing is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-04-2014, 12:46 AM   #2
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
Get your tune checked and also check all of the connections on and near CAI. Something may be loose or off.

Sent from the future.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 05-04-2014, 12:07 PM   #3
Registered Member
Regular
 
G3racing's Avatar
 
Join Date: Feb 2014
Location: Houston
Region: Texas
Posts: 163
What do you mean tune checked

Sent from my SAMSUNG-SGH-I337 using Mustang Evolution mobile app
__________________
2014 Mustang V6 Manual
AMR Charcoal Wheel & NITTO Tire Kit - 20x8.5
G3racing is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-04-2014, 03:30 PM   #4
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
Exactly what I said. Get with whoever built your tune, and have then go over it again to make sure they didn't get something wrong.

Sent from the future.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 05-04-2014, 03:58 PM   #5
Registered Member
Regular
 
PonyBoyV6's Avatar
 
Join Date: Aug 2011
Location: Chicago Area
Region: Illinois
Posts: 1,079
I'd start with checking the MAF and any and all vacuum lines. Very easily could have shook a line lose, or dirtied, or even broke the mass airflow sensor. Did this all start immediately after installing the CAI?
PonyBoyV6 is offline   Reply With Quote
Old 05-04-2014, 07:34 PM   #6
Registered Member
Regular
 
G3racing's Avatar
 
Join Date: Feb 2014
Location: Houston
Region: Texas
Posts: 163
It worked fine for a couple hours then messed up

Sent from my SAMSUNG-SGH-I337 using Mustang Evolution mobile app
__________________
2014 Mustang V6 Manual
AMR Charcoal Wheel & NITTO Tire Kit - 20x8.5
G3racing is offline   Reply With Quote
Old 05-04-2014, 08:25 PM   #7
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
Have you done anything we've suggested yet and did you find anything? The MAF is a good call by PonyBoyV6. When I installed my CAI, the two screws holding the MAF in backed out, causing the MAF to be very loose.

Sent from the future.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 05-04-2014, 09:42 PM   #8
Registered Member
Regular
 
G3racing's Avatar
 
Join Date: Feb 2014
Location: Houston
Region: Texas
Posts: 163
I tightened the metal zip ties and made sure everything was connected well then reset my computer by unhooking the negative on battery then tuned it check engine light went away but I feel less power than I should when I get on it and also should rpms at idle be a like 500-700

Sent from my SAMSUNG-SGH-I337 using Mustang Evolution mobile app
__________________
2014 Mustang V6 Manual
AMR Charcoal Wheel & NITTO Tire Kit - 20x8.5
G3racing is offline   Reply With Quote
Old 05-04-2014, 09:59 PM   #9
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
My idle is around 750. Who did your tune, because you should be able to get them to datalog the tune to see if they can get the power you're looking for. They can also adjust your idle rpm if it's too low.

Sent from the future.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 05-05-2014, 09:15 AM   #10
Registered Member
Regular
 
G3racing's Avatar
 
Join Date: Feb 2014
Location: Houston
Region: Texas
Posts: 163
I have a Bama tuner and when my car idles the rpm needle moves up and down a little bit and my car rumbles it never did this before cai and tune

Sent from my SAMSUNG-SGH-I337 using Mustang Evolution mobile app
__________________
2014 Mustang V6 Manual
AMR Charcoal Wheel & NITTO Tire Kit - 20x8.5
G3racing is offline   Reply With Quote
Old 05-05-2014, 09:51 AM   #11
Registered Member
Regular
 
PonyBoyV6's Avatar
 
Join Date: Aug 2011
Location: Chicago Area
Region: Illinois
Posts: 1,079
What model year is this car? Also, If you have a bama handheld, Use the Check engine function. If the light is not there, it should still show pending CEL codes. You'll probably have a p1000 code from resetting the battery, but ignore that. See if anything else pops up.
PonyBoyV6 is offline   Reply With Quote
Old 05-05-2014, 11:23 AM   #12
Registered Member
Regular
 
G3racing's Avatar
 
Join Date: Feb 2014
Location: Houston
Region: Texas
Posts: 163
2014 v6 the code was for bank 1 being to lean

Sent from my SAMSUNG-SGH-I337 using Mustang Evolution mobile app
__________________
2014 Mustang V6 Manual
AMR Charcoal Wheel & NITTO Tire Kit - 20x8.5
G3racing is offline   Reply With Quote
Old 05-05-2014, 06:58 PM   #13
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
If you're tuned through Bama, you should have 3 tunes. Have you tried loading either of the other two tunes yet?

Sent from the future.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 05-12-2014, 01:57 PM   #14
Registered User
Newbie
 
pete2013's Avatar
 
Join Date: Jan 2014
Location: Aviano Italy
Region: Europe
Posts: 13
The oil on the after market filter might have fouled the air flow sensor
pete2013 is offline   Reply With Quote
Old 05-15-2014, 06:32 PM   #15
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
So did your issue ever get resolved?

Sent from the future.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 05-15-2014, 07:56 PM   #16
Registered Member
Regular
 
G3racing's Avatar
 
Join Date: Feb 2014
Location: Houston
Region: Texas
Posts: 163
Quote:
Originally Posted by WhoDat View Post
If you're tuned through Bama, you should have 3 tunes. Have you tried loading either of the other two tunes yet?

Sent from the future.
It has something to do with the 2014 computer and the adaptive shifting thing relearn feature

Sent from my SAMSUNG-SGH-I337 using Mustang Evolution mobile app
__________________
2014 Mustang V6 Manual
AMR Charcoal Wheel & NITTO Tire Kit - 20x8.5
G3racing is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > General Mustang Discussion

Tags
check engine

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Fuel Cap & Service Engine Soon Light??????? mattstang Pre-2005 V6 Mustang 8 12-25-2006 02:33 PM
check engine soon light finally off stangracer Pre-2005 V6 Mustang 4 02-04-2004 11:41 AM
Check Engine Light MUSTANGJUNKY420 Pre-2005 V6 Mustang 11 08-09-2003 01:29 AM
Check engine light, codes inside, cause? MUSTANGJUNKY420 Pre-2005 V6 Mustang 1 08-03-2003 09:24 AM
Check engine light, codes inside, cause? MUSTANGJUNKY420 Pre-2005 V6 Mustang 2 07-30-2003 01:22 AM

» Like Us On Facebook



07:44 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.