sqeaking in the engine? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-14-2012, 11:06 PM   #1
Registered User
Newbie
 
zalizar21's Avatar
 
Join Date: May 2012
Region: Michigan
Posts: 8
sqeaking in the engine?

I was changing the water pump got some radiator fluid on the pulley system mind you this was 2 week ago and ever since then have had a squeaking in the in the engine. Any suggestion on what it might be guys?
zalizar21 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-15-2012, 06:39 PM   #2
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
Quote:
Originally Posted by zalizar21
I was changing the water pump got some radiator fluid on the pulley system mind you this was 2 week ago and ever since then have had a squeaking in the in the engine. Any suggestion on what it might be guys?
Well I would say a wet belt but should be dry after two weeks lol...maybe you didn't line up the belt properly?
08Mustang is offline   Reply With Quote
Old 05-17-2012, 06:41 PM   #3
Registered Member
Regular
 
Mr. SoloDolo's Avatar
 
Join Date: Dec 2011
Region: Louisiana
Posts: 224
was it concentrated fluid? If so it has a high oily like substance maybe it got on a pulley or something :-/
Mr. SoloDolo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-17-2012, 06:59 PM   #4
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
Quote:
Originally Posted by Mr. SoloDolo
was it concentrated fluid? If so it has a high oily like substance maybe it got on a pulley or something :-/
Yeah antifreeze will make it squeak for a few cranks if you get it on a pulley
08Mustang is offline   Reply With Quote
Old 05-18-2012, 06:01 PM   #5
Registered Member
Regular
 
245ciPony's Avatar
 
Join Date: May 2012
Region: New York
Posts: 193
I've been having the same problem with my 06 after spilling coolant on the belt. I can't figure out which pulley is squeaking either since it only does it while im driving.
245ciPony is offline   Reply With Quote
Old 05-18-2012, 08:56 PM   #6
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
Quote:
Originally Posted by 245ciPony
I've been having the same problem with my 06 after spilling coolant on the belt. I can't figure out which pulley is squeaking either since it only does it while im driving.
Just take off the belt and clean em all
08Mustang is offline   Reply With Quote
Old 05-18-2012, 11:58 PM   #7
Registered Member
Regular
 
gc19662007's Avatar
 
Join Date: Aug 2011
Region: Texas
Posts: 216
Also not a bad idea to check the radiator cap. Mine was starting to fail to the point it would barely squirt out and make the belt squeak but not boil over. That drove me nuts for a couple of weeks before it ended up going completely bad.
gc19662007 is offline   Reply With Quote
Old 05-19-2012, 07:16 AM   #8
Registered Member
Regular
 
kf4myo's Avatar
 
Join Date: Jan 2012
Location: Lehigh Acres
Region: Florida
Posts: 74
When I had a squeaky noise I bought a can of belt dressing from the auto parts and sprayed the belt. That worked for me.
kf4myo is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:12 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.