Noisy Suspension - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-22-2012, 12:25 AM   #1
Registered Member
Regular
 
05.BCA.Mach1's Avatar
 
Join Date: Aug 2012
Region: Tennessee
Posts: 23
Noisy Suspension

I've been hearing a popping sound in my right front suspension. It has been on 7 racks (2 Ford dealers, 3 small shop mechanics, 1 Chevy dealer, and 1 private mechanic) and NOBODY can find anything wrong with it!

It makes two different sounds.
1) sounds like, well, the wheel from wheel of fortune LOL :/ no other way o describe it makes sense
2) a clunking pop sound

Both noises are heard when turning, and seem to be coming from the right front. I've *heard* that everything is fine with my suspension, nothing dry, nothing loose, no real reason it should be popping.

I'm thinking... either LCA issues (remember someone telling me a few years ago something about bad bushings on the s197's, don't really remember the details) -- or -- maybe I have a bad hub?

If you've been through this, please help! I'm at my wit's end with this.
05.BCA.Mach1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-22-2012, 09:11 PM   #2
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Quote:
Originally Posted by 05.BCA.Mach1
I've been hearing a popping sound in my right front suspension. It has been on 7 racks (2 Ford dealers, 3 small shop mechanics, 1 Chevy dealer, and 1 private mechanic) and NOBODY can find anything wrong with it!

It makes two different sounds.
1) sounds like, well, the wheel from wheel of fortune LOL :/ no other way o describe it makes sense
2) a clunking pop sound

Both noises are heard when turning, and seem to be coming from the right front. I've *heard* that everything is fine with my suspension, nothing dry, nothing loose, no real reason it should be popping.

I'm thinking... either LCA issues (remember someone telling me a few years ago something about bad bushings on the s197's, don't really remember the details) -- or -- maybe I have a bad hub?

If you've been through this, please help! I'm at my wit's end with this.
I'm afraid I can't solve the puzzle.. Hmm I've never heard of that before.
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 08-23-2012, 11:52 AM   #3
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
U don't think tire rod ends are broken our try replacing the tire rods end boot adding grease
05MUSTANG4.0L is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-23-2012, 05:29 PM   #4
Registered Member
Regular
 
05.BCA.Mach1's Avatar
 
Join Date: Aug 2012
Region: Tennessee
Posts: 23
Re: Noisy Suspension

Have added grease -- Tie rod ends were replaced, after this started. So I know that's not it.
05.BCA.Mach1 is offline   Reply With Quote
Old 08-25-2012, 05:53 AM   #5
Registered Member
Regular
 
StangRebel's Avatar
 
Join Date: Mar 2012
Region: Canada
Posts: 61
Re: Noisy Suspension

If it was in the rear i could tell you, i had that noise there
StangRebel is offline   Reply With Quote
Old 08-27-2012, 12:27 PM   #6
Registered Member
Regular
 
05.BCA.Mach1's Avatar
 
Join Date: Aug 2012
Region: Tennessee
Posts: 23
Re: Noisy Suspension

Yeah, I initially thought sway bar bushings bc I'd dealt with it before with another vehicle. So I don't know yet. :/
05.BCA.Mach1 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:15 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.