Squeak Sounds - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-18-2012, 11:41 AM   #1
Registered Member
Regular
 
BoLtThEhUsKy's Avatar
 
Join Date: Feb 2011
Region: Arizona
Posts: 212
Squeak Sounds

I was on the way to the track on Saturday and for half the trip I was hearing a low squeak sound coming from the back of the car. I drove it again today and it's now making the sound when I go over speed bumps.
BoLtThEhUsKy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-18-2012, 11:46 AM   #2
Registered Member
Regular
 
jellybean82881's Avatar
 
Join Date: Jun 2012
Region: Illinois
Posts: 56
I've had a squeak in mine too for a while. It's when I apply the brakes. I took it in and they took it all apart, cleaned it and they said it went away. Ummmmm..... No its still doing it. So I'm gonna have to take it back in to Ford and snap. I mean, how embarrassing is it to have a brand new car that squeaks?
jellybean82881 is offline   Reply With Quote
Old 09-18-2012, 11:48 AM   #3
Registered Member
Regular
 
BoLtThEhUsKy's Avatar
 
Join Date: Feb 2011
Region: Arizona
Posts: 212
Mine is an '05 and it hasn't started doing it till Saturday, or atleast never noticed it. It only happens when in motion, not normally when braking.
BoLtThEhUsKy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-18-2012, 01:27 PM   #4
Registered Member
Regular
 
grbird88's Avatar
 
Join Date: Sep 2012
Location: Tallmadge
Region: Ohio
Posts: 27
Re: Squeak Sounds

I have the same noise. I believe it's the bushings on the rear sway bar and links. I sprayed the bushing with silicone and that helped but I just noticed it starting again.
grbird88 is offline   Reply With Quote
Old 09-18-2012, 02:04 PM   #5
Registered Member
Regular
 
BoLtThEhUsKy's Avatar
 
Join Date: Feb 2011
Region: Arizona
Posts: 212
I'll take a look at it when I get home.
BoLtThEhUsKy is offline   Reply With Quote
Old 09-18-2012, 07:24 PM   #6
Registered Member
Regular
 
Wmcgrattan's Avatar
 
Join Date: Aug 2012
Region: Florida
Posts: 488
I had the same problem with mine !!! I toke it to ford to get it taken care off an they said it was a warped rotor an they cut the rotor an it still made a bad sound so I bought eBay slotted rotors an I haven't had a problem since an they have 12k on it now
Wmcgrattan is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:09 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.