my car wont starrt:/ - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-19-2013, 04:46 PM   #1
Road Trip!
 
Join Date: Sep 2012
Region: California
Posts: 610
my car wont starrt:/

I took it for a shower and when i was coming home it was feeling rough idling at stop lights.. When i got home i parked and now that im trying to start it it wont..
Andy714 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-19-2013, 04:49 PM   #2
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Did you try to wash the engine?
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 01-19-2013, 05:14 PM   #3
Road Trip!
 
Join Date: Sep 2012
Region: California
Posts: 610
No it was just a normal car wash.. I tried jump starting it but it wont.. Lights and radio work.. And it makes a click sound when i try to turn it on
Andy714 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-23-2013, 07:42 PM   #4
Registered Member
Regular
 
MustacheMustang's Avatar
 
Join Date: Aug 2012
Region: Texas
Posts: 247
Quote:
Originally Posted by Andy714 View Post
No it was just a normal car wash.. I tried jump starting it but it wont.. Lights and radio work.. And it makes a click sound when i try to turn it on
same thing happen to my car minus the weird idling at stops, my suggestions are to have someone with a hammer tap the alternator while someone starts it. and if that works I believe you need to replace your starter, but if it doesn't, then it's more likely your starter because once I replaced that, it's started and make sure your battery is good too and that the things wrapped around your negative and positive are on tight an snug. do a little research too man, and good luck.
MustacheMustang is offline   Reply With Quote
Old 01-23-2013, 07:55 PM   #5
Road Trip!
 
Join Date: Sep 2012
Region: California
Posts: 610
I fixed it. It was the negative head that conects to the battery. It was loose i might need a new one
Andy714 is offline   Reply With Quote
Old 01-24-2013, 06:18 AM   #6
Registered Member
Regular
 
MustacheMustang's Avatar
 
Join Date: Aug 2012
Region: Texas
Posts: 247
Quote:
Originally Posted by Andy714 View Post
I fixed it. It was the negative head that conects to the battery. It was loose i might need a new one
that's great bro!! mine was actually my starter and when my dad replaced it, it still didn't start and so I got bummed out but I open the hood and my dad tighten either the positive head or negative head and it started and mannn, it was one of those feelings like "IT'S ALIIIIVVVE, ITSSS AALIIIIIVVVVVEEE!!" haha.
MustacheMustang is offline   Reply With Quote
Old 01-24-2013, 09:57 AM   #7
Road Trip!
 
Join Date: Sep 2012
Region: California
Posts: 610
Quote:
Originally Posted by MustacheMustang View Post

that's great bro!! mine was actually my starter and when my dad replaced it, it still didn't start and so I got bummed out but I open the hood and my dad tighten either the positive head or negative head and it started and mannn, it was one of those feelings like "IT'S ALIIIIVVVE, ITSSS AALIIIIIVVVVVEEE!!" haha.
Haha i know dude i tought it was going to be the alt.. But those cables get lose sometimes and cause trouble
Andy714 is offline   Reply With Quote
Old 01-24-2013, 10:23 PM   #8
Registered Member
Regular
 
MustacheMustang's Avatar
 
Join Date: Aug 2012
Region: Texas
Posts: 247
Quote:
Originally Posted by Andy714 View Post

Haha i know dude i tought it was going to be the alt.. But those cables get lose sometimes and cause trouble
right, lol.
MustacheMustang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:39 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.