shaking at low RPM? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-06-2013, 02:50 PM   #1
Registered Member
Regular
 
Avenged7892's Avatar
 
Join Date: May 2012
Region: Virginia
Posts: 62
shaking at low RPM?

Hey everybody,

I just recently put the screamin demon coil, taylor wires, and ngk iridium plugs in gapped to .065. I don't know if its related, but just recently when I shift from D to P, the RPM ocassionly drops to about 500 and the car shudders. Any ideas?
Avenged7892 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-06-2013, 03:01 PM   #2
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
Quote:
Originally Posted by Avenged7892 View Post
Hey everybody,

I just recently put the screamin demon coil, taylor wires, and ngk iridium plugs in gapped to .065. I don't know if its related, but just recently when I shift from D to P, the RPM ocassionly drops to about 500 and the car shudders. Any ideas?
Fuel issue...either bad pump or clogged filter or lines or injectors
08Mustang is offline   Reply With Quote
Old 02-06-2013, 03:13 PM   #3
Registered Member
Regular
 
Avenged7892's Avatar
 
Join Date: May 2012
Region: Virginia
Posts: 62
Thanks for the quick reply. I'm not great about troubleshooting those things myself... Anything I can do to narrow it down?
Avenged7892 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-06-2013, 04:29 PM   #4
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
Quote:
Originally Posted by Avenged7892 View Post
Thanks for the quick reply. I'm not great about troubleshooting those things myself... Anything I can do to narrow it down?
Not sure about that but have you ever replaced the fuel filter and where do you get gas at?
08Mustang is offline   Reply With Quote
Old 02-06-2013, 04:45 PM   #5
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
And your plugs are gapped too far, need to be gapped to .050
08Mustang is offline   Reply With Quote
Old 02-06-2013, 04:46 PM   #6
Registered Member
Regular
 
Avenged7892's Avatar
 
Join Date: May 2012
Region: Virginia
Posts: 62
No I haven't replaced the fuel filter. I usually get my 93 gas at local exxon or shell stations.
Avenged7892 is offline   Reply With Quote
Old 02-06-2013, 05:08 PM   #7
Registered Member
Regular
 
Avenged7892's Avatar
 
Join Date: May 2012
Region: Virginia
Posts: 62
For the screaming demon coil it recommends. 065
Avenged7892 is offline   Reply With Quote
Old 02-06-2013, 05:11 PM   #8
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
Quote:
Originally Posted by Avenged7892 View Post
For the screaming demon coil it recommends. 065
That just seems pretty dang far to me...try closing it some and then see and if the problem doesn't stop then buy a new filter and see if that helps
08Mustang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:17 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.