Idle drop - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-23-2013, 08:59 AM   #1
Registered User
Newbie
 
blooce's Avatar
 
Join Date: Sep 2012
Region: Florida
Posts: 7
Idle drop

I am not sure why but just recently my 06 mustang will drop rpm while idling at red lights. Just for a second then go right back to a strong consistent idle. It happens every 25 seconds or so. Not sure why. Runs strong with no issues when driving and the engine light is not on. Any ideas?
blooce is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-23-2013, 12:11 PM   #2
Registered Member
Regular
 
usmc.Cavanaugh's Avatar
 
Join Date: Feb 2012
Location: Bayville/tabernacle
Region: New Jersey
Posts: 47
How's your coil pack and all the wires and plugs ever change them out I had the same problem it would drop rpms and while driving my lights would randomly dim I change all that **** out runs like a champ and has a smoother idle
usmc.Cavanaugh is offline   Reply With Quote
Old 02-23-2013, 12:34 PM   #3
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
Mine has done this since I got it with 28,xxx miles on it. It will drop than surge back up kind if annoying
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-23-2013, 04:02 PM   #4
Registered User
Newbie
 
blooce's Avatar
 
Join Date: Sep 2012
Region: Florida
Posts: 7
I have not changed the coils. Is there away to test to see if coils are going bad?
blooce is offline   Reply With Quote
Old 02-23-2013, 08:26 PM   #5
Registered Member
Regular
 
usmc.Cavanaugh's Avatar
 
Join Date: Feb 2012
Location: Bayville/tabernacle
Region: New Jersey
Posts: 47
Quote:
Originally Posted by blooce View Post
I have not changed the coils. Is there away to test to see if coils are going bad?
I mean you should on have one coil pack it's like a distributor where the wires go to from the plugs I have no idea what voltage should it pushing it out or how to tell I just changed it and it went away yours could be a different problem or it could be the same just throwing an idea to help you out the coil pack is on the driver side toward the back and middle if that helps you find it
usmc.Cavanaugh is offline   Reply With Quote
Old 03-19-2013, 09:26 PM   #6
Registered Member
Regular
 
06v6mustang's Avatar
 
Join Date: Sep 2012
Region: Ohio
Posts: 29
Mine does the same thing, it would drop down to about 4-500 rpm and then go back up and for some reason my car also idles at a little over 600 I changed the air filter and cleaned the mass air flow sensor and it ran a ton better but then did it again
06v6mustang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



03:14 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.