Laundry List of Issues - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-02-2013, 01:03 AM   #1
Registered Member
Regular
 
Join Date: Dec 2011
Location: Henderson
Region: Nevada
Posts: 22
Laundry List of Issues

So lately I've been losing power to my car entirely. What happens is I drive it, everything ok, park the car, turn the ignition off then get out and shut the door, few seconds later try to lock the door with the remote and nothing happens, open the door, no interior lights, put the key in the ignition nothing. Pop the hood and bam power restored. Loose wire electrical issue? Cleaned the battery good negative is fine the positive side has me only slightly worried as it seems to still be a little loose-ish so I'm thinking of trying a new clamp I don't want to buy all new cables. I'm guessing power restoration on hood pop and loss of power on door shut must be attributed to the cable? Yet when you drive on the road and hit potholes power never is lost maybe the lights dim a little. After cleaning and reconnecting the battery I now get a CD Error on my Shaker 500. The computer for miles to empty goes haywire and always resets sometimes stating 400 miles to empty then a minute later only 100 same thing if you disconnect the battery. Having major electrical issues. The cars been hit parked before and the alarm failed to go off it was a busted headlight and the hood bent. My most major concern is the fact if you ever need to do a panic stop the brake pedal will depress all the way to the floor and you will hear what sounds like plastic grinding and almost a total loss of brake function the master cylinder was replaced but not much improved. Everything else is fine when checked by a tech. If people sit in back I can hear a lot of squeaking in the seat or the suspension not sure where its coming from exactly. The electrical in the car resets a lot. I'm starting to wonder if even a possible issue with the computer chip. Of course all of these things ford wants a thousand dollars just to diagnose when things were under warranty and brought in they did not want to fix. Also traveling at 60mph you can hear a high pitched whine when you accelerate only between 60-65 mph any less or greater and the noise stops as well as if you lay off the accelerator. Only get about 90 miles to a full tank in the city I just don't know whats going on its properly maintained just its like everything is going haywire all of the sudden in it. these all seem like minor issue minus the brake issue and electrical/computer which does make up a majority some of the other issue are just annoyances. I really love the car just never thought it would suddenly have a ton of weird unexplainable problems and glitches. Anyone have any advice? Thanks in advance!
cjd_1986 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-02-2013, 01:16 AM   #2
Registered Member
Regular
 
DaBluedude's Avatar
 
Join Date: Oct 2008
Region: Canada
Posts: 1,996
Can we get a tl;dr version please...
__________________
2003 Mach 1
DaBluedude is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Members Mustangs

Shelby

kikker

Todd

tjzola
Add your Mustang
» Like Us On Facebook



07:22 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.