engine light - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-03-2013, 05:08 PM   #1
Registered Member
Regular
 
goatsoup's Avatar
 
Join Date: Apr 2012
Region: Maine
Posts: 115
engine light

Hey guys engine light came on saying bank 1 and bank 2 were running lean. I just recently got pypes true dual exhaust, would that cause it? My idle isnt as smooth as it was. Also abs and tcs are not working. Code reader said rr failed then on next one it said rr missing. But I just got it replaced.
goatsoup is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-03-2013, 09:47 PM   #2
Registered Member
Regular
 
Joe_Roma5's Avatar
 
Join Date: Jul 2012
Location: Saint Paul
Region: Minnesota
Posts: 137
Same happened to me, but not until after i installed the no tune cai. Duals were the first thing i did and had no problems
__________________
'06 4.0 V6 custom x pipes, cai, screamin demon coil pack, 10mm live wires spark plug wires, NGK iridium plugs, 93 octane bama tune
Joe_Roma5 is offline   Reply With Quote
Old 03-03-2013, 10:12 PM   #3
Registered Member
Regular
 
goatsoup's Avatar
 
Join Date: Apr 2012
Region: Maine
Posts: 115
Ya I also got no tune cai, did u replace o2 sensors?
goatsoup is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-04-2013, 12:54 AM   #4
Registered Member
Regular
 
Joe_Roma5's Avatar
 
Join Date: Jul 2012
Location: Saint Paul
Region: Minnesota
Posts: 137
I would recommend getting the tuner. Some of the "no tune required" cai's actually do require a tune even though they are less restrictive then the cai that do require a tune.
__________________
'06 4.0 V6 custom x pipes, cai, screamin demon coil pack, 10mm live wires spark plug wires, NGK iridium plugs, 93 octane bama tune
Joe_Roma5 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:12 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.