Service engine soon - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-05-2013, 09:29 PM   #1
Registered User
Newbie
 
Random fury's Avatar
 
Join Date: May 2013
Location: Hayden
Region: Idaho
Posts: 14
Service engine soon

So Last night my cars service engine soon light came on shortly after idling somewhat rough...didnt seem too bad, and about a 1/4 mile later it flashed on. I went to o'reillys and hooked up a scanner and it came back with 4 codes. P0174, P0171 saying bank 1 and 2 are running lean. The other 2 P2096 and P2098 came back with no results in there system but I have seen 2 different answers online saying Post Catalyst Fuel Trim System Too Lean or both banks running rich. Im confused lol. Now it seems first gear has no power till the car gets rolling. I cleared the codes to see if they would come back and filled up with new gas which Im hoping was the issue. Anyone got any ideas on the combination of these codes? I noticed others have has both sets the 174&171 or 2096 and 2098 but not all 4.

(Just after I got my new qtr window blackout decals too )
Random fury is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-05-2013, 09:37 PM   #2
Registered Member
Regular
 
Boomdizzle's Avatar
 
Join Date: Feb 2013
Location: Cincinnati
Region: Ohio
Posts: 681
I had some similar issues and I ended up cleaning my mass air sensor, replacing my fuel filter, and running injector cleaner and the codes haven't come back. I thought it could be an exhaust leak, intake leak, or bad o2 sensors but what I said I did above seemed to clear it up. All those things together cost about $15 so that may be worth a shot to start with.
__________________
Torque: It's like crack for your right foot
Boomdizzle is offline   Reply With Quote
Old 06-05-2013, 10:02 PM   #3
Registered User
Newbie
 
Random fury's Avatar
 
Join Date: May 2013
Location: Hayden
Region: Idaho
Posts: 14
Cool deal ill have to give that a shot if they come back...wish I woulda ran some injector cleaner thru with that tank...thanks!
Random fury is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-06-2013, 12:11 AM   #4
Registered Member
Regular
 
Terminator's Avatar
 
Join Date: Nov 2011
Region: California
Posts: 983
Quote:
Originally Posted by Boomdizzle View Post
I had some similar issues and I ended up cleaning my mass air sensor, replacing my fuel filter, and running injector cleaner and the codes haven't come back. I thought it could be an exhaust leak, intake leak, or bad o2 sensors but what I said I did above seemed to clear it up. All those things together cost about $15 so that may be worth a shot to start with.
Ill try these sugg. Since I have exact issue lol
Terminator is offline   Reply With Quote
Old 06-06-2013, 09:08 AM   #5
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
Quote:
Originally Posted by Boomdizzle View Post
I had some similar issues and I ended up cleaning my mass air sensor, replacing my fuel filter, and running injector cleaner and the codes haven't come back. I thought it could be an exhaust leak, intake leak, or bad o2 sensors but what I said I did above seemed to clear it up. All those things together cost about $15 so that may be worth a shot to start with.
Yeah I run injector cleaner about once every couple months and just replaced my fuel filter and my mpg went through the roof!
08Mustang is offline   Reply With Quote
Old 06-06-2013, 11:41 PM   #6
Registered User
Newbie
 
Random fury's Avatar
 
Join Date: May 2013
Location: Hayden
Region: Idaho
Posts: 14
What kinda numbers are we talkin? Lol
Random fury is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:58 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.