HELP! Loud squeaking!!! - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-18-2013, 09:24 PM   #1
Registered Member
Regular
 
Joe_Roma5's Avatar
 
Join Date: Jul 2012
Location: Saint Paul
Region: Minnesota
Posts: 137
HELP! Loud squeaking!!!

I can hear noticeable squeaking coming from the rear and i have no clue what it is. Very annoying, and makes my car sound like poop. I did notice it when i rock back and forth as well. Any suggestions would be great
__________________
'06 4.0 V6 custom x pipes, cai, screamin demon coil pack, 10mm live wires spark plug wires, NGK iridium plugs, 93 octane bama tune
Joe_Roma5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-18-2013, 11:08 PM   #2
Registered Member
Regular
 
Terminator's Avatar
 
Join Date: Nov 2011
Region: California
Posts: 983
Quote:
Originally Posted by Joe_Roma5 View Post
I can hear noticeable squeaking coming from the rear and i have no clue what it is. Very annoying, and makes my car sound like poop. I did notice it when i rock back and forth as well. Any suggestions would be great
Anything you've done to ur car most recently
Terminator is offline   Reply With Quote
Old 06-18-2013, 11:18 PM   #3
Registered Member
Regular
 
Zhim's Avatar
 
Join Date: Dec 2012
Location: Richmond
Region: Canada
Posts: 137
I got that too. Squeaks when going over speed bumps and shifting. Started noticing it after I upgraded my springs and struts to ford racing ones. don't think anything's loose, so probably bushings wearing out?
Zhim is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-19-2013, 12:49 AM   #4
Registered Member
Regular
 
Joe_Roma5's Avatar
 
Join Date: Jul 2012
Location: Saint Paul
Region: Minnesota
Posts: 137
Only thing i have done back there is cat back exhaust
__________________
'06 4.0 V6 custom x pipes, cai, screamin demon coil pack, 10mm live wires spark plug wires, NGK iridium plugs, 93 octane bama tune
Joe_Roma5 is offline   Reply With Quote
Old 06-19-2013, 11:36 AM   #5
Registered Member
Regular
 
grbird88's Avatar
 
Join Date: Sep 2012
Location: Tallmadge
Region: Ohio
Posts: 27
I have the same issue too. It appears to be the bushing on sway bar, etc. I sprayed all of the rubber bushings in the rear with silcone. That seems to have help stop the noise. I have done it a couple of times in the last year and have not had the problem for 6 or 7 months. Good luck
grbird88 is offline   Reply With Quote
Old 06-19-2013, 11:48 AM   #6
Registered Member
Regular
 
Zhim's Avatar
 
Join Date: Dec 2012
Location: Richmond
Region: Canada
Posts: 137
Well then, time for sway bar upgrades lol
Zhim is offline   Reply With Quote
Old 06-21-2013, 05:29 PM   #7
Registered Member
Regular
 
Stratstang's Avatar
 
Join Date: Jun 2013
Location: Oshawa
Region: Canada
Posts: 140
I have the same issue. It's the lca's on my car. Liberally spraying WD40 or silicone spray helps as a temp fix, but really they need to be replaced.
Stratstang is offline   Reply With Quote
Old 06-24-2013, 03:08 PM   #8
Registered Member
Regular
 
Join Date: Dec 2012
Location: Seattle
Region: Washington
Posts: 28
Had this for awhile on my old 94 V6, but was coming from the front. Ball joint went kaboom.
__________________
Scoobuh is offline   Reply With Quote
Old 06-24-2013, 03:26 PM   #9
Registered Member
Regular
 
Joe_Roma5's Avatar
 
Join Date: Jul 2012
Location: Saint Paul
Region: Minnesota
Posts: 137
Im getting so many different answers! And still no clue what it is! Shocks? Sway bar? Ball joint? Control arms?!?
__________________
'06 4.0 V6 custom x pipes, cai, screamin demon coil pack, 10mm live wires spark plug wires, NGK iridium plugs, 93 octane bama tune
Joe_Roma5 is offline   Reply With Quote
Old 06-24-2013, 05:27 PM   #10
Registered Member
Regular
 
Stratstang's Avatar
 
Join Date: Jun 2013
Location: Oshawa
Region: Canada
Posts: 140
Quote:
Originally Posted by Joe_Roma5 View Post
Im getting so many different answers! And still no clue what it is! Shocks? Sway bar? Ball joint? Control arms?!?
The cheap way to find out is to lube the lca's, then the sway bar and so on until you stop the squeak. It'll just cost you a can of silicone spray. Then fix the problem properly. I had a ball joint go on my '09. It didn't squeak at all, but made a clunk when going over bumps, like driveways etc.
Stratstang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:00 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.