Leaking coolant - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-26-2013, 01:45 PM   #1
Registered User
Newbie
 
Join Date: Nov 2012
Region: New York
Posts: 1
Leaking coolant

I have a 2006 mustang and I've been losing coolant out of my thermometer housing. It spurts out when I rev the engine or accelerate fast. I have already replaced the entire housing unit and it started leaking again about 2 weeks later. Any ideas on any sealant, or if I maybe need to get the entire system flushed in case there's a back up?
denises08 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-26-2013, 02:24 PM   #2
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
Quote:
Originally Posted by denises08 View Post
I have a 2006 mustang and I've been losing coolant out of my thermometer housing. It spurts out when I rev the engine or accelerate fast. I have already replaced the entire housing unit and it started leaking again about 2 weeks later. Any ideas on any sealant, or if I maybe need to get the entire system flushed in case there's a back up?
My thermostat housing started leaking very badly around 61k miles and is a very common issue on the 4.0...I replace my housing and it's still fine 10k miles later so I'm not sure man
08Mustang is offline   Reply With Quote
Old 07-26-2013, 03:16 PM   #3
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Did you use a new gasket? Did you use RTV? if so how much and on what side of the gasket? Was the gasket facing the right direction??
Billymich is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-26-2013, 07:24 PM   #4
Registered Member
Regular
 
Stratstang's Avatar
 
Join Date: Jun 2013
Location: Oshawa
Region: Canada
Posts: 140
Quote:
Originally Posted by 08Mustang View Post

My thermostat housing started leaking very badly around 61k miles and is a very common issue on the 4.0...I replace my housing and it's still fine 10k miles later so I'm not sure man
Me too, but at around 90K miles. I did the housing, thermostat and a flush and fill at the same time. It's only been about 6 weeks, but so far so good.

---------- Post added at 08:24 PM ---------- Previous post was at 08:20 PM ----------

Quote:
Originally Posted by denises08 View Post
I have a 2006 mustang and I've been losing coolant out of my thermometer housing. It spurts out when I rev the engine or accelerate fast. I have already replaced the entire housing unit and it started leaking again about 2 weeks later. Any ideas on any sealant, or if I maybe need to get the entire system flushed in case there's a back up?
Did a shop do the work? If so, go back there. They should stand behind their work. Could be something dumb like wrong torque specs or something allowing a gap for coolant to leak from.
Stratstang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



08:03 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.