2005 speedo prob - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-15-2013, 02:38 PM   #1
Registered User
Newbie
 
Dasco61's Avatar
 
Join Date: Sep 2013
Location: pine hill
Region: New Jersey
Posts: 1
2005 speedo prob

I have a v6 2005 4.0 and my speedo has stopped working it has acted funny before and fuel guage but always went back after restart now its stuck at 58mph disconnect batt still not working ??? should i just get new cluster or get used from scrap yard. thanks Dan
Dasco61 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-16-2013, 06:37 PM   #2
Registered Member
Regular
 
Knooper3's Avatar
 
Join Date: Aug 2011
Location: Brasov
Region: Europe
Posts: 173
you can buy some new motors for the gauges. they fixed this problem from 2006 but ours still have it. i'll do so too, i've already bought the motors but didn't have the time. if you are careful with the calibration, then you should have a cheap fix
Knooper3 is offline   Reply With Quote
Old 09-24-2013, 10:42 AM   #3
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
Quote:
Originally Posted by Knooper3 View Post
you can buy some new motors for the gauges. they fixed this problem from 2006 but ours still have it. i'll do so too, i've already bought the motors but didn't have the time. if you are careful with the calibration, then you should have a cheap fix
Were did you buy the motors and how much did you pay for them
05MUSTANG4.0L is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-26-2013, 07:50 AM   #4
Registered Member
Regular
 
Knooper3's Avatar
 
Join Date: Aug 2011
Location: Brasov
Region: Europe
Posts: 173
Quote:
Originally Posted by 05MUSTANG4.0L View Post
Were did you buy the motors and how much did you pay for them
ebay about $46 but it takes a while because they come from china. though i still have a problem with the fuel gauge it seems. and i had them soldered by a professional. but i'll check today all the electronics linked to it
Knooper3 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



08:33 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.