Motor problem... - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-04-2014, 03:19 PM   #1
Registered User
Newbie
 
cobrazbutterfly's Avatar
 
Join Date: Mar 2014
Posts: 4
Motor problem...

2006 V6 Mustang

Sent from my SAMSUNG-SGH-I527 using Mustang Evolution mobile app
cobrazbutterfly is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-04-2014, 03:22 PM   #2
Registered User
Newbie
 
cobrazbutterfly's Avatar
 
Join Date: Mar 2014
Posts: 4
HELP 2006 V6 mustang motor problems

Ive had no problems until one night I got into my car and started to go up the road. The low oil pressure light came on and then the car shut off. Still wont start. Took it to the shop and they pulled off the valve cover and the valves isnt moving. They checked the front timing chain and it is still ok. HELP... what else could it be???

Sent from my SAMSUNG-SGH-I527 using Mustang Evolution mobile app
cobrazbutterfly is offline   Reply With Quote
Old 03-06-2014, 02:09 PM   #3
Registered Member
Regular
 
LivelyMustang's Avatar
 
Join Date: Nov 2013
Location: Kenosha
Region: Wisconsin
Posts: 156
Motor problem...

None of the valves are moving? Or just the pressure valve?
LivelyMustang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-06-2014, 02:14 PM   #4
Registered Member
Regular
 
LivelyMustang's Avatar
 
Join Date: Nov 2013
Location: Kenosha
Region: Wisconsin
Posts: 156
Motor problem...

It could be the oil pressure relief valve. A piece of debris from using the wrong type of oil or a piece of the oil filter could be stuck in there holding open the valvr
LivelyMustang is offline   Reply With Quote
Old 03-06-2014, 03:40 PM   #5
Registered User
Newbie
 
cobrazbutterfly's Avatar
 
Join Date: Mar 2014
Posts: 4
They took off one valve cover and they said none is moving on that side at all.
cobrazbutterfly is offline   Reply With Quote
Old 03-13-2014, 02:40 PM   #6
Registered User
Newbie
 
cobrazbutterfly's Avatar
 
Join Date: Mar 2014
Posts: 4
Looks like new motor for my mustang
cobrazbutterfly is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:17 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.