Mustang gauges - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-28-2014, 09:34 AM   #1
Registered User
Newbie
 
lop05's Avatar
 
Join Date: Mar 2014
Location: kerrville
Region: Texas
Posts: 8
Mustang gauges

Any one know the solution behinde miss reading gauges on 05 mustang V6

Sent from my LG-P769 using Mustang Evolution mobile app
lop05 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-29-2014, 10:16 PM   #2
Registered Member
Regular
 
G3ARH3AD's Avatar
 
Join Date: Mar 2014
Location: spartanburg
Region: South Carolina
Posts: 158
What is misreading?
G3ARH3AD is offline   Reply With Quote
Old 03-30-2014, 01:15 AM   #3
Registered User
Newbie
 
lop05's Avatar
 
Join Date: Mar 2014
Location: kerrville
Region: Texas
Posts: 8
The whole dashboard rpm,temp.gas.and speed

Sent from my LG-P769 using Mustang Evolution mobile app
lop05 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-30-2014, 06:46 AM   #4
Registered Member
Regular
 
G3ARH3AD's Avatar
 
Join Date: Mar 2014
Location: spartanburg
Region: South Carolina
Posts: 158
Sounds like some wiring may b loose of shorting for all the gauges not to b working, but still could b a bad cluster as well. Ive never seen all of them go out at once
G3ARH3AD is offline   Reply With Quote
Old 03-30-2014, 09:11 AM   #5
Registered User
Newbie
 
lop05's Avatar
 
Join Date: Mar 2014
Location: kerrville
Region: Texas
Posts: 8
Yea sounds like it and when I drive it the only thing that works is the rpm

Sent from my LG-P769 using Mustang Evolution mobile app
lop05 is offline   Reply With Quote
Old 03-30-2014, 09:20 AM   #6
Registered Member
Regular
 
G3ARH3AD's Avatar
 
Join Date: Mar 2014
Location: spartanburg
Region: South Carolina
Posts: 158
Pull the cluster out and check the connector on the back
G3ARH3AD is offline   Reply With Quote
Old 03-30-2014, 09:28 AM   #7
Registered User
Newbie
 
lop05's Avatar
 
Join Date: Mar 2014
Location: kerrville
Region: Texas
Posts: 8
Do you think it could be a fuse as well

Sent from my LG-P769 using Mustang Evolution mobile app
lop05 is offline   Reply With Quote
Old 03-30-2014, 11:11 AM   #8
Registered Member
Regular
 
G3ARH3AD's Avatar
 
Join Date: Mar 2014
Location: spartanburg
Region: South Carolina
Posts: 158
Pull the cluster out and check the connector on the back

---------- Post added at 12:11 PM ---------- Previous post was at 12:10 PM ----------

Sorry disnt mean to post that twice but doubt its a fuse
G3ARH3AD is offline   Reply With Quote
Old 03-30-2014, 11:02 PM   #9
Registered Member
Regular
 
07 S197's Avatar
 
Join Date: Aug 2013
Location: Edgerton
Region: Minnesota
Posts: 133
I think you gauge cluster motors are going bad. This was a common problem with cars built before a certain date.( not sure when exactly)
07 S197 is offline   Reply With Quote
Old 03-31-2014, 09:02 AM   #10
Registered Member
Regular
 
cj92's Avatar
 
Join Date: Oct 2013
Location: duncan
Region: Oklahoma
Posts: 60
Yeah you either have to replace the stepper motors or the whole gauge cluster.. Or you could upgrade to the my color option

Sent from my glade plugin
cj92 is offline   Reply With Quote
Old 03-31-2014, 09:18 AM   #11
Registered User
Newbie
 
lop05's Avatar
 
Join Date: Mar 2014
Location: kerrville
Region: Texas
Posts: 8
You know how much a gauge cluster is?

Sent from my LG-P769 using Mustang Evolution mobile app

---------- Post added at 09:18 AM ---------- Previous post was at 09:17 AM ----------

I pulled the cluster out and it was connected

Sent from my LG-P769 using Mustang Evolution mobile app
lop05 is offline   Reply With Quote
Old 03-31-2014, 12:02 PM   #12
Registered Member
Regular
 
cj92's Avatar
 
Join Date: Oct 2013
Location: duncan
Region: Oklahoma
Posts: 60
Its like 300 dollars or $200 from the stealership

Sent from my glade plugin
cj92 is offline   Reply With Quote
Old 03-31-2014, 01:24 PM   #13
Registered User
Newbie
 
lop05's Avatar
 
Join Date: Mar 2014
Location: kerrville
Region: Texas
Posts: 8
Thanks bro

Sent from my LG-P769 using Mustang Evolution mobile app
lop05 is offline   Reply With Quote
Old 04-03-2014, 11:48 PM   #14
Registered Member
Regular
 
Lmo36's Avatar
 
Join Date: Oct 2013
Location: Greenwood
Region: Indiana
Posts: 141
Happend to my jeep one time it was a fuse
__________________
Current Vehicle: 2012 Black Mustang 3.7 with a k&n 69 typhoon sieries CAI Ford racing Strut tower brace Forgestar f14s on the way 😈 | Past vehicles Ford ranger | 2001 Jeep Wranger | 2007 White v6 mustang |

Lmo36 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FORD MUSTANG 96-98 GT White Faced Halo Gauges Kiljosh Mustang Parts for Sale and Wanted 1 06-13-2005 11:01 PM
2005 Mustang Gauges *DIAL UP WARNING* synister232 The Bar 26 11-07-2003 08:23 PM

» Like Us On Facebook



06:24 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.