Transmission problems - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-29-2014, 09:21 AM   #1
Registered User
Newbie
 
Join Date: Mar 2014
Location: midland
Region: Canada
Posts: 1
Transmission problems

I have a 2005 base mustang 6 cylinder with an automatic transmission. The reverse does not work when the car is cold works better when car is warm. The over drive light is flashing. Do i need a new tranny.
brent5258 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-29-2014, 10:09 PM   #2
Registered Member
Regular
 
G3ARH3AD's Avatar
 
Join Date: Mar 2014
Location: spartanburg
Region: South Carolina
Posts: 158
How many miles also those cars have a 5r55s trans which are not the best imo but od light usually means over heating temps but can b just electrical, but since ur reverse only works when it warm sounds like a bad seal for that part
G3ARH3AD is offline   Reply With Quote
Old 08-30-2015, 04:55 PM   #3
Registered User
Newbie
 
dorkdog's Avatar
 
Join Date: May 2015
Location: puyallup
Region: Washington
Posts: 19
Sorry to revive an old thread but enough is enough!

It has been mentioned several times in several laces that these are supposedly 'sealed units' because they have no dipstick? Yet, I have also discovered that they have a drain port AND a fill port - that does not follow my definition of a 'sealed unit'. There has also been confusion as to how often the trans should be serviced - 30K or 80K?

I will add to this confusion by relating that I had my AT fluid checked when I bought my 2010 V6 in May 2015, with only 40K, and the fluid was 'just starting to turn'.
dorkdog is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-30-2015, 07:56 PM   #4
Registered Member
Regular
 
JokerS197's Avatar
 
Join Date: Jan 2015
Posts: 93
Quote:
Originally Posted by dorkdog View Post
Sorry to revive an old thread but enough is enough!

It has been mentioned several times in several laces that these are supposedly 'sealed units' because they have no dipstick? Yet, I have also discovered that they have a drain port AND a fill port - that does not follow my definition of a 'sealed unit'. There has also been confusion as to how often the trans should be serviced - 30K or 80K?

I will add to this confusion by relating that I had my AT fluid checked when I bought my 2010 V6 in May 2015, with only 40K, and the fluid was 'just starting to turn'.

Yeah the new trans don't have the dip stick. The only way to do anything transmission wise is if you have the trans fluid injector hose thing. I believe the manual says ever 80k, I drained it once.


Sent from my iPad using Mustang Evolution
JokerS197 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems and more problems BigB227 1996-2004 Mustang GT 1 08-22-2012 10:12 AM
Transmission problems Hons67 2.3 Mustang 5 05-30-2011 05:16 PM
Auto transmission problems. 6opka Pre-2005 V6 Mustang 4 04-18-2009 03:38 PM
02 Mustang Possible Transmission Problems TK225 General Mustang Discussion 3 10-07-2008 07:41 AM
Transmission Question: 1997 V6 Automatic Transmission ?? svtmustang88 Pre-2005 V6 Mustang 4 12-09-2003 05:49 PM

» Like Us On Facebook



05:30 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.