No power - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-26-2015, 10:32 AM   #1
Registered Member
Regular
 
Texas22's Avatar
 
Join Date: Sep 2014
Location: Dallas
Region: Texas
Posts: 205
No power

So this morning I got in my car, turned on just fine, everything was normal. Went on about a 20-25 minute drive to go eat, drive was fine, everything still normal. Was in chick fil a for about 45 minutes to an hour and when I tried to start my car to leave there was absolutely no power. Didn't even do the "clicking" noise it makes when it's dead. Tried to jump it, but would barely crank. When I unplugged the battery it went back to no power. What do yall think? Bad battery? But battery is only a year old. Give me some help
Texas22 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-26-2015, 10:41 AM   #2
Registered Member
Regular
 
509pony's Avatar
 
Join Date: Oct 2014
Posts: 324
Was it cranking but not starting or nothing at all?

Sent from my SGH-T999L using Mustang Evolution mobile app
509pony is offline   Reply With Quote
Old 02-26-2015, 11:04 AM   #3
Registered Member
Regular
 
Texas22's Avatar
 
Join Date: Sep 2014
Location: Dallas
Region: Texas
Posts: 205
Cranking a little when it was connected to another battery, other than that, literally nothing
Texas22 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-26-2015, 11:24 AM   #4
Registered Member
Regular
 
509pony's Avatar
 
Join Date: Oct 2014
Posts: 324
If there's no crank I think you have a bad battery th as t needs to be replaced or charged if there is I think it maybe your started or ignition switch but I would do the battery first

Sent from my SGH-T999L using Mustang Evolution mobile app
509pony is offline   Reply With Quote
Old 02-26-2015, 11:45 AM   #5
Registered Member
Regular
 
Texas22's Avatar
 
Join Date: Sep 2014
Location: Dallas
Region: Texas
Posts: 205
Thanks! I'll try it in a while
Texas22 is offline   Reply With Quote
Old 02-26-2015, 12:13 PM   #6
Registered Member
Regular
 
Taylor_SS's Avatar
 
Join Date: Feb 2015
Posts: 104
It might be the battery, or it might be the starter.


Sent from my iPhone using Mustang Evolution
Taylor_SS is offline   Reply With Quote
Old 02-26-2015, 07:52 PM   #7
Registered Member
Regular
 
Texas22's Avatar
 
Join Date: Sep 2014
Location: Dallas
Region: Texas
Posts: 205
Battery is good, but positive wire is very corroded. Gonna clean it as well as I can and see if it'll crank
Texas22 is offline   Reply With Quote
Old 02-26-2015, 07:54 PM   #8
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
Quote:
Originally Posted by Texas22 View Post
Battery is good, but positive wire is very corroded. Gonna clean it as well as I can and see if it'll crank
Fill a small bowl with diet coke and put it in there

Sent from my VS985 4G using Mustang Evolution mobile app
natestang07 is offline   Reply With Quote
Old 02-26-2015, 09:04 PM   #9
Registered Member
Regular
 
Texas22's Avatar
 
Join Date: Sep 2014
Location: Dallas
Region: Texas
Posts: 205
Turns out that the wire and terminal on the positive side were the culprits. Will be replacing this soon. Has anybody ever replaced them? If so, tips/how to would be appreciated!
Texas22 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2005-2010 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
It takes power to make power sporter 2005-2010 Mustang GT 3 05-13-2007 07:40 PM
Power antenna pics? ASSEMbler Mustang Audio & Video 6 09-26-2004 09:33 PM
I need a power wire to splice into. Rellik Pre-2005 V6 Mustang 22 07-30-2003 12:56 PM
Noticeable Power from CAI and Dual Exhaust? Stang01 Pre-2005 V6 Mustang 11 07-29-2003 06:17 PM
best mods for top end power MusclesFromBrussels Pre-2005 V6 Mustang 5 07-18-2003 11:54 AM

» Like Us On Facebook



06:50 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.